summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSune Vuorela <debian@pusling.com>2008-04-15 20:38:41 +0000
committerSune Vuorela <debian@pusling.com>2008-04-15 20:38:41 +0000
commit7ba3bcca53d022e4b9921642e875283f4293815a (patch)
tree38f23b54bdf1525b5f7405ec01162950f826b547 /debian
parent9559a137173444b07cfad0d789d409c59f1315a5 (diff)
downloadqt4-x11-7ba3bcca53d022e4b9921642e875283f4293815a.tar.gz
fix qmake makefile generation. I wonder if it has any side effects
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rw-r--r--debian/patches/15_fix_qmake_makefile_generation.diff13
-rw-r--r--debian/patches/series1
3 files changed, 17 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 86e4bc7..14708f4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -12,12 +12,14 @@ qt4-x11 (4.4.0~rc1-4) unstable; urgency=low
* Add a disabled patch to generate better prl files, but unfortunately too
much of qt4 build process relies on on it and is not yet fixed, but it is
saved for later use.
+ * Fix qmake makefile generation - should not add double slashes to
+ makefiles.
+++ Changes by Matthew Rosewarne:
* Add Recommends: qt4-doc to qt4-demos.
- -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Sat, 12 Apr 2008 18:14:01 +0200
+ -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Tue, 15 Apr 2008 22:37:01 +0200
qt4-x11 (4.4.0~rc1-3) unstable; urgency=low
diff --git a/debian/patches/15_fix_qmake_makefile_generation.diff b/debian/patches/15_fix_qmake_makefile_generation.diff
new file mode 100644
index 0000000..1cd3e10
--- /dev/null
+++ b/debian/patches/15_fix_qmake_makefile_generation.diff
@@ -0,0 +1,13 @@
+Index: b/qmake/generators/makefile.cpp
+===================================================================
+--- a/qmake/generators/makefile.cpp
++++ b/qmake/generators/makefile.cpp
+@@ -2334,7 +2334,7 @@
+
+ QString mkfile = subtarget->makefile;
+ if(!in_directory.isEmpty())
+- mkfile.prepend(out_directory);
++ mkfile.prepend(out_directory + Option::dir_sep);
+
+ QString in_directory_cdin, in_directory_cdout, out_directory_cdin, out_directory_cdout;
+ #define MAKE_CD_IN_AND_OUT(directory) \
diff --git a/debian/patches/series b/debian/patches/series
index 614e04c..5fafeb3 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -23,6 +23,7 @@
11_qdbus_to_dbus_fix.diff
12_fix_qmake_pkgconfig.diff
14_add_libraries_to_gui_build_where_actually_needed.diff
+15_fix_qmake_makefile_generation.diff
20_mips_atomic_ops.diff
40_alpha_ice.diff
41_disable_opengl_visibility.diff