summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorLisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>2012-08-18 15:45:15 -0300
committerLisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>2012-08-18 15:45:15 -0300
commit7c78fb2715ea63e462c3c0e85f0b4ea23cf24a31 (patch)
treed5cf69ddadd7eb92f2770a74f6870eefb61669df /debian
parente940bf45c17c8399d1f5279a60c09f181fe4d07e (diff)
downloadqt4-x11-7c78fb2715ea63e462c3c0e85f0b4ea23cf24a31.tar.gz
Add upstream patch Fix-cursor-truncate-to-include-line-position.patch
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/Fix-cursor-truncate-to-include-line-position.patch32
-rw-r--r--debian/patches/series1
3 files changed, 35 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 75a72c9..1646eb5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,8 @@ qt4-x11 (4:4.8.2+dfsg-1) UNRELEASED; urgency=low
- Add prune-nonfree to debian/rules to remove them.
- Add a note on README.source of what we are removing from the original
tarball.
+ * Add upstream patch Fix-cursor-truncate-to-include-line-position.patch
+ needed for Calligra and katepart.
-- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Sat, 18 Aug 2012 15:14:31 -0300
diff --git a/debian/patches/Fix-cursor-truncate-to-include-line-position.patch b/debian/patches/Fix-cursor-truncate-to-include-line-position.patch
new file mode 100644
index 0000000..25d4a7a
--- /dev/null
+++ b/debian/patches/Fix-cursor-truncate-to-include-line-position.patch
@@ -0,0 +1,32 @@
+Description: Fix cursor truncate to include line position
+ Since we could have moved the line position (QTextLine::setPosition),
+ the truncating position should be adjusted with that.
+
+Origin: commit ca89c49fa2c5cbb3945897046f33eed9f7da846c
+Author: Jiang Jiang <jiang.jiang@nokia.com>
+Reviewed-by: Eskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@nokia.com>
+Applied-Upstream: yes
+Forwarded: not-needed
+
+---
+ src/gui/text/qtextlayout.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/gui/text/qtextlayout.cpp b/src/gui/text/qtextlayout.cpp
+index 16f7150..52f2793 100644
+--- a/src/gui/text/qtextlayout.cpp
++++ b/src/gui/text/qtextlayout.cpp
+@@ -2616,8 +2616,8 @@ qreal QTextLine::cursorToX(int *cursorPos, Edge edge) const
+ x += eng->offsetInLigature(si, pos, end, glyph_pos);
+ }
+
+- if (eng->option.wrapMode() != QTextOption::NoWrap && x > line.width)
+- x = line.width;
++ if (eng->option.wrapMode() != QTextOption::NoWrap && x > line.x + line.width)
++ x = line.x + line.width;
+
+ *cursorPos = pos + si->position;
+ return x.toReal();
+--
+1.7.10.4
+
diff --git a/debian/patches/series b/debian/patches/series
index adb61a5..5522a5c 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -3,6 +3,7 @@ Add_support_for_QT_USE_DRAG_DISTANCE_env_var.patch
QTBUG-14724_close_orphaned_file_descriptors_after_printing.patch
QTBUG-21900_Buttons_in_Qt_applications_not_clickable_when_run_under_gnome-shell.patch
QElfParser-fix-type-of-sh_size.patch
+Fix-cursor-truncate-to-include-line-position.patch
# qt-copy patches
0195-compositing-properties.diff