summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSune Vuorela <debian@pusling.com>2008-04-14 20:53:52 +0000
committerSune Vuorela <debian@pusling.com>2008-04-14 20:53:52 +0000
commit91613de4a458256014eb0c49172bf030abdfa427 (patch)
treef8c96560206b53ead1f302a972aea097b0678ac6 /debian
parente722a35f6a6e9bddb3088a57f4f65021128ba0b8 (diff)
downloadqt4-x11-91613de4a458256014eb0c49172bf030abdfa427.tar.gz
fix up pc files and postprocess prl files
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog9
-rw-r--r--debian/patches/12_fix_qmake_pkgconfig.diff13
-rw-r--r--debian/patches/13_fix_prl_files_dont_link_entire_world.diff.disabled15
-rw-r--r--debian/patches/14_add_libraries_to_gui_build_where_actually_needed.diff33
-rw-r--r--debian/patches/series2
-rwxr-xr-xdebian/rules2
6 files changed, 73 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a32de4b..52c40a8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,15 @@
qt4-x11 (4.4.0~rc1-4) unstable; urgency=low
* Have libqt4-dev conflict/replace libqtwebkit-dev.
+ * Fix qmake to generate a bit better pkg-config files. Those should usually
+ not be generated - as it ends up being crackful. After a bit of patching
+ they are a bit less crackful though.
+ * Postprocess prl files to remove the same crack as in the pc files.
+ * Do a bit nicer linking when needed instead of relying on crackfulness from
+ prl and pc files.
+ * Add a disabled patch to generate better prl files, but unfortunately too
+ much of qt4 build process relies on on it and is not yet fixed, but it is
+ saved for later use.
-- Sune Vuorela <debian@pusling.com> Sat, 12 Apr 2008 18:14:01 +0200
diff --git a/debian/patches/12_fix_qmake_pkgconfig.diff b/debian/patches/12_fix_qmake_pkgconfig.diff
new file mode 100644
index 0000000..3e93a0f
--- /dev/null
+++ b/debian/patches/12_fix_qmake_pkgconfig.diff
@@ -0,0 +1,13 @@
+Index: b/qmake/generators/unix/unixmake2.cpp
+===================================================================
+--- a/qmake/generators/unix/unixmake2.cpp
++++ b/qmake/generators/unix/unixmake2.cpp
+@@ -1440,6 +1440,8 @@
+ pkgConfiglibName = "-l" + lname.left(lname.length()-Option::libtool_ext.length());
+ }
+ t << pkgConfiglibDir << " " << pkgConfiglibName << " ";
++ t << endl;
++ t << "Libs.private: ";
+ for(QStringList::ConstIterator it = libs.begin(); it != libs.end(); ++it) {
+ t << project->values((*it)).join(" ") << " ";
+ }
diff --git a/debian/patches/13_fix_prl_files_dont_link_entire_world.diff.disabled b/debian/patches/13_fix_prl_files_dont_link_entire_world.diff.disabled
new file mode 100644
index 0000000..8194603
--- /dev/null
+++ b/debian/patches/13_fix_prl_files_dont_link_entire_world.diff.disabled
@@ -0,0 +1,15 @@
+Index: b/qmake/generators/makefile.cpp
+===================================================================
+--- a/qmake/generators/makefile.cpp
++++ b/qmake/generators/makefile.cpp
+@@ -971,8 +971,8 @@
+ else
+ libs << "QMAKE_LIBS"; //obvious one
+ t << "QMAKE_PRL_LIBS = ";
+- for(QStringList::Iterator it = libs.begin(); it != libs.end(); ++it)
+- t << project->values((*it)).join(" ") << " ";
++// for(QStringList::Iterator it = libs.begin(); it != libs.end(); ++it)
++// t << project->values((*it)).join(" ") << " ";
+ t << endl;
+ }
+ }
diff --git a/debian/patches/14_add_libraries_to_gui_build_where_actually_needed.diff b/debian/patches/14_add_libraries_to_gui_build_where_actually_needed.diff
new file mode 100644
index 0000000..d68cc24
--- /dev/null
+++ b/debian/patches/14_add_libraries_to_gui_build_where_actually_needed.diff
@@ -0,0 +1,33 @@
+Index: b/src/gui/kernel/kernel.pri
+===================================================================
+--- a/src/gui/kernel/kernel.pri
++++ b/src/gui/kernel/kernel.pri
+@@ -112,6 +112,7 @@
+ HEADERS += \
+ kernel/qguieventdispatcher_glib_p.h
+ QMAKE_CXXFLAGS += $$QT_CFLAGS_GLIB
++ LIBS +=$$QT_LIBS_GLIB
+ }
+ SOURCES += \
+ kernel/qeventdispatcher_x11.cpp
+@@ -140,6 +141,7 @@
+ HEADERS += \
+ kernel/qeventdispatcher_glib_qws_p.h
+ QMAKE_CXXFLAGS += $$QT_CFLAGS_GLIB
++ LIBS +=$$QT_LIBS_GLIB
+ }
+
+
+Index: b/src/gui/painting/painting.pri
+===================================================================
+--- a/src/gui/painting/painting.pri
++++ b/src/gui/painting/painting.pri
+@@ -63,6 +63,8 @@
+ painting/qpathclipper.cpp \
+ painting/qmemrotate.cpp
+
++LIBS += -lz
++
+ DEFINES += QT_RASTER_IMAGEENGINE
+ win32:DEFINES += QT_RASTER_PAINTENGINE
+ embedded:DEFINES += QT_RASTER_PAINTENGINE
diff --git a/debian/patches/series b/debian/patches/series
index eafeb6c..614e04c 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -21,6 +21,8 @@
09_qmake_lflags_as-needed.diff
10_config_tests_fixes.diff
11_qdbus_to_dbus_fix.diff
+12_fix_qmake_pkgconfig.diff
+14_add_libraries_to_gui_build_where_actually_needed.diff
20_mips_atomic_ops.diff
40_alpha_ice.diff
41_disable_opengl_visibility.diff
diff --git a/debian/rules b/debian/rules
index 032e824..ec12755 100755
--- a/debian/rules
+++ b/debian/rules
@@ -186,7 +186,7 @@ common-install-arch::
find $(DEB_DESTDIR)/usr/lib -type f -name '*.prl' \
-exec perl -pi -e "s, -L$(CURDIR)/\S+,,g" {} \;
find $(DEB_DESTDIR)/usr/lib -type f -name '*.prl' \
- -exec sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" {} \;
+ -exec sed -i -e "/^QMAKE_PRL_BUILD_DIR/d;s/(QMAKE_PRL_LIBS =).*/\1/" {} \;
install/libqtcore4::
$(CURDIR)/bin/lrelease-qt4 debian/translations/qt_ca.ts \