summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSune Vuorela <debian@pusling.com>2008-06-08 06:37:05 +0000
committerSune Vuorela <debian@pusling.com>2008-06-08 06:37:05 +0000
commitb67237bdb86cd4e2e0d9d83c45e75f3df89294e8 (patch)
treed80ab255805e5bcbc84667c094e93e7bda8cab2f /debian
parentf49332c792ead8adaa49ff58250832e84ded20e8 (diff)
downloadqt4-x11-b67237bdb86cd4e2e0d9d83c45e75f3df89294e8.tar.gz
Fix generic atomic header. (Closes: #475767)
This is enough to fix building of kdelibs, but there should be a proper hppa fix modelled over the other "real" archs. +++ Changes by Fathi Boudra:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog10
-rw-r--r--debian/patches/72_generic_arch_atomic_header_fix.diff17
-rw-r--r--debian/patches/series1
3 files changed, 26 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index abb50e5..cc416b1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,10 @@
-qt4-x11 (4.4.0-3) UNRELEASED; urgency=low
+qt4-x11 (4.4.0-3) unstable; urgency=low
+
+ * Fix generic atomic header. (Closes: #475767)
+ This is enough to fix building of kdelibs, but there should be a proper
+ hppa fix modelled over the other "real" archs.
+
+ +++ Changes by Fathi Boudra:
* Add qt-copy patch:
* 0230-qtextcontrol-selectnextword
@@ -8,7 +14,7 @@ qt4-x11 (4.4.0-3) UNRELEASED; urgency=low
* 0231- !!! we wait for ipv6 fix !!!
- -- Fathi Boudra <fabo@debian.org> Sat, 31 May 2008 09:23:04 +0200
+ -- Sune Vuorela <debian@pusling.com> Sun, 08 Jun 2008 08:28:00 +0200
qt4-x11 (4.4.0-2) unstable; urgency=low
diff --git a/debian/patches/72_generic_arch_atomic_header_fix.diff b/debian/patches/72_generic_arch_atomic_header_fix.diff
new file mode 100644
index 0000000..a6a1f8d
--- /dev/null
+++ b/debian/patches/72_generic_arch_atomic_header_fix.diff
@@ -0,0 +1,17 @@
+http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=475767
+
+This mostly affects hppa, but hppa is "community supported" - meaning that the Trolls doesn't care much.
+
+Index: b/src/corelib/arch/qatomic_generic.h
+===================================================================
+--- a/src/corelib/arch/qatomic_generic.h
++++ b/src/corelib/arch/qatomic_generic.h
+@@ -223,7 +223,7 @@
+ Q_INLINE_TEMPLATE T *QBasicAtomicPointer<T>::fetchAndStoreOrdered(T *newValue)
+ {
+ return reinterpret_cast<T *>
+- (QBasicAtomicPointer_fetchAndStoreOrdered(&reinterpret_cast<void * volatile *>(&_q_value),
++ (QBasicAtomicPointer_fetchAndStoreOrdered(reinterpret_cast<void * volatile *>(&_q_value),
+ newValue));
+ }
+
diff --git a/debian/patches/series b/debian/patches/series
index 921a662..d283370 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -35,5 +35,6 @@
60_m68k_inotify_fix.diff
70_hppa_ldcw_fix.diff
71_hppa_unaligned_access_fix_458133.diff
+72_generic_arch_atomic_header_fix.diff
80_hurd_max_path.diff
90_gcc43.diff