summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorLisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>2013-09-13 12:37:47 -0300
committerLisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>2013-09-13 12:37:47 -0300
commitd18e414ea2d251a2dc9fae4bc7218a80fd7d6339 (patch)
tree40f38e055975ec230ecf23a64eb7bc8b8cbd27cc /debian
parentb55077e8c99648264ca6ce12710e5068e01b8af1 (diff)
downloadqt4-x11-d18e414ea2d251a2dc9fae4bc7218a80fd7d6339.tar.gz
Fix shortcuts with secondary xkb layout.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rw-r--r--debian/patches/fix_shortcuts_with_secondary_xkb_layout.patch40
-rw-r--r--debian/patches/series1
3 files changed, 45 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 04ca5d8..13f896a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,9 @@
qt4-x11 (4:4.8.5+dfsg-5) UNRELEASED; urgency=low
+ [ Lisandro Damián Nicanor Pérez Meyer ]
+ * Add fix_shortcuts_with_secondary_xkb_layout.patch taken from upstream.
+ Thanks Boris Pek for pointing it out (Closes: #719064).
+
-- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Fri, 13 Sep 2013 12:36:03 -0300
qt4-x11 (4:4.8.5+dfsg-4) unstable; urgency=low
diff --git a/debian/patches/fix_shortcuts_with_secondary_xkb_layout.patch b/debian/patches/fix_shortcuts_with_secondary_xkb_layout.patch
new file mode 100644
index 0000000..0cb948f
--- /dev/null
+++ b/debian/patches/fix_shortcuts_with_secondary_xkb_layout.patch
@@ -0,0 +1,40 @@
+From 8660bb907ef132f2c7c774a7b05f96bf8cab00e6 Mon Sep 17 00:00:00 2001
+From: Gatis Paeglis <gatis.paeglis@digia.com>
+Date: Sat, 31 Aug 2013 21:22:47 +0200
+Subject: [PATCH] Revert "QTBUG-15319: fix shortcuts with secondary Xkb
+ layout."
+
+The change which attempted to fix QTBUG-15319 broke keyboard
+shortcuts for non latin keyboard layouts.
+
+This patch reverts QTBUG-15319 (f45cdeda8) since it caused a
+regression.
+
+Task-number: QTBUG-32908
+
+Change-Id: I47d7984fa7986d5218d1f3ff1fc36d2ec67c9ba7
+---
+ src/gui/kernel/qkeymapper_x11.cpp | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/src/gui/kernel/qkeymapper_x11.cpp b/src/gui/kernel/qkeymapper_x11.cpp
+index 005ff3f..7daa41d 100644
+--- a/src/gui/kernel/qkeymapper_x11.cpp
++++ b/src/gui/kernel/qkeymapper_x11.cpp
+@@ -282,12 +282,9 @@ QList<int> QKeyMapperPrivate::possibleKeysXKB(QKeyEvent *event)
+
+ // first, translate key only using lock modifiers (there are no Qt equivalents for these, so we must
+ // always use them when determining the baseKeySym)
+- // Note: the Xkb group to be used for the conversion keycode->keysym has to be given to
+- // XkbLookupKeySym(). This information is contained in the bits 8 to 15 of xmodifiers.
+- // See https://bugreports.qt-project.org/browse/QTBUG-15319 .
+ KeySym baseKeySym;
+ uint consumedModifiers;
+- if (!XkbLookupKeySym(X11->display, xkeycode, (xmodifiers & (0xff00 | LockMask | qt_num_lock_mask)),
++ if (!XkbLookupKeySym(X11->display, xkeycode, (xmodifiers & (LockMask | qt_num_lock_mask)),
+ &consumedModifiers, &baseKeySym))
+ return QList<int>();
+
+--
+1.8.4.rc3
+
diff --git a/debian/patches/series b/debian/patches/series
index 286d023..1c4ead0 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -2,6 +2,7 @@
Add_support_for_QT_USE_DRAG_DISTANCE_env_var.patch
QTBUG-21900_Buttons_in_Qt_applications_not_clickable_when_run_under_gnome-shell.patch
Add-support-for-the-Linux-m68k-platform.patch
+fix_shortcuts_with_secondary_xkb_layout.patch
# qt-copy patches
0195-compositing-properties.diff