summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSune Vuorela <debian@pusling.com>2008-06-12 10:14:17 +0000
committerSune Vuorela <debian@pusling.com>2008-06-12 10:14:17 +0000
commite7e3c0b345eca1310872ae5153b3a2c8e1db622a (patch)
tree2c681754a0e4082743c1de30a662ef74b86f874c /debian
parent90549d6d842612afd8ee1f0a891d472629d63637 (diff)
downloadqt4-x11-e7e3c0b345eca1310872ae5153b3a2c8e1db622a.tar.gz
Get patch from 4.4.2 to allow Https to be treated as https in -network.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/0002_https_lowercase.cpp35
-rw-r--r--debian/patches/series1
3 files changed, 37 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 8f81dad..7457537 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ qt4-x11 (4.4.0-4) unstable; urgency=low
* Get patch from 4.4.2 (yes!) to fix painting of scrollbars in webkit with
some styles.
+ * Get patch from 4.4.2 to allow Https to be treated as https in -network.
-- Sune Vuorela <debian@pusling.com> Wed, 11 Jun 2008 23:22:22 +0200
diff --git a/debian/patches/0002_https_lowercase.cpp b/debian/patches/0002_https_lowercase.cpp
new file mode 100644
index 0000000..3c900d4
--- /dev/null
+++ b/debian/patches/0002_https_lowercase.cpp
@@ -0,0 +1,35 @@
+Fetched from 4.4.2
+treat Https, HTtps, hTTps, ... as https as well
+
+Index: b/src/network/access/qnetworkaccesshttpbackend.cpp
+===================================================================
+--- a/src/network/access/qnetworkaccesshttpbackend.cpp
++++ b/src/network/access/qnetworkaccesshttpbackend.cpp
+@@ -64,7 +64,7 @@
+ static QByteArray makeCacheKey(const QUrl &url)
+ {
+ QUrl copy = url;
+- bool isEncrypted = url.scheme() == QLatin1String("https");
++ bool isEncrypted = url.scheme().toLower() == QLatin1String("https");
+ copy.setPort(url.port(isEncrypted ? DefaultHttpsPort : DefaultHttpPort));
+ return "http-connection:" + copy.toEncoded(QUrl::RemovePassword | QUrl::RemovePath |
+ QUrl::RemoveQuery | QUrl::RemoveFragment);
+@@ -88,7 +88,8 @@
+ }
+
+ QUrl url = request.url();
+- if (url.scheme() == QLatin1String("http") || url.scheme() == QLatin1String("https"))
++ QString scheme = url.scheme().lower();
++ if (scheme == QLatin1String("http") || scheme == QLatin1String("https"))
+ return new QNetworkAccessHttpBackend;
+
+ return 0;
+@@ -309,7 +310,7 @@
+ void QNetworkAccessHttpBackend::open()
+ {
+ QUrl url = request().url();
+- bool encrypt = url.scheme() == QLatin1String("https");
++ bool encrypt = url.scheme().toLower() == QLatin1String("https");
+ setAttribute(QNetworkRequest::ConnectionEncryptedAttribute, encrypt);
+
+ // set the port number in the reply if it wasn't set
diff --git a/debian/patches/series b/debian/patches/series
index acb148c..e164907 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,5 +1,6 @@
# patches from upstream
0001_webkit_backround_in_scrollbars_webkit-5b0ea6b840a6e25e97b886e1852c3fc6ef8e8d0d.diff
+0002_https_lowercase.cpp
# qt-copy patches
0167-fix-group-reading.diff
0180-window-role.diff