summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules66
1 files changed, 29 insertions, 37 deletions
diff --git a/debian/rules b/debian/rules
index cfbd6c0..ec4a327 100755
--- a/debian/rules
+++ b/debian/rules
@@ -50,9 +50,6 @@ ifeq ($(DEB_HOST_ARCH),arm)
endif
armv6_architectures := armhf
-ifeq ($(vendor),Ubuntu)
- armv6_architectures += armel
-endif
ifeq ($(DEB_HOST_ARCH),$(findstring $(DEB_HOST_ARCH), $(armv6_architectures)))
extra_configure_opts += -arch armv6
endif
@@ -89,7 +86,7 @@ else
endif
endif
-no_pch_architectures := armhf ia64
+no_pch_architectures := armhf ia64 powerpc ppc64
ifeq ($(DEB_HOST_ARCH),$(findstring $(DEB_HOST_ARCH), $(no_pch_architectures)))
extra_configure_opts += -no-pch
endif
@@ -115,7 +112,7 @@ endif
# Create mkspecs/glibc-g++ from mkspecs/linux-g++, needed by GNU/kFreeBSD
# we cannot use directly linux-g++ due to src/corelib/io/io.pri
- rm -rf mkspecs/glibc-g++
+ rm -rfv mkspecs/glibc-g++
cp -a mkspecs/linux-g++ mkspecs/glibc-g++
# Dyson support: like linux, but with illumos kernel and libc:
@@ -125,7 +122,7 @@ endif
# Remove include directory. Then ./configure will take care of calling
# syncqt and regenerating it.
- rm -rf include
+ rm -rfv include
./configure -confirm-license \
-prefix "/usr" \
@@ -196,7 +193,7 @@ override_dh_auto_clean:
# Extra stuff missed by confclean/distclean
# Misc. files
- rm -f \
+ rm -fv \
config.status \
config.tests/.qmake.cache \
examples/dbus/*/Makefile.* \
@@ -205,7 +202,7 @@ override_dh_auto_clean:
;
# Misc. directories
- rm -rf \
+ rm -rfv \
doc-build/ \
doc/html/ \
doc/qch/ \
@@ -219,7 +216,7 @@ override_dh_auto_clean:
;
# hppa test directory
- rm -rf debian/hppa-tmp
+ rm -rfv debian/hppa-tmp
# Leftover dirs
find -depth -type d \( -false \
@@ -234,7 +231,7 @@ override_dh_auto_clean:
-o -name release-shared \
-o -name release-static \
-o -name .uic \
- \) -print0 | xargs -0 rm -rf
+ \) -print0 | xargs -0 rm -rfv
# Leftover files and all symlinks
find \( -false \
@@ -246,7 +243,7 @@ override_dh_auto_clean:
-o -name \*.so \
-o -name \*.so.debug \
-o -type l \
- \) -print0 | xargs -0 rm -rf
+ \) -print0 | xargs -0 rm -rfv
# Delete all Makefiles, excluding some from src/3rdparty
find $(CURDIR) -name Makefile \
@@ -254,26 +251,22 @@ override_dh_auto_clean:
! -path $(CURDIR)/src/3rdparty/freetype/\* \
! -path $(CURDIR)/src/3rdparty/zlib/\* \
! -path $(CURDIR)/src/3rdparty/ptmalloc/Makefile \
- -print0 | xargs -0 rm -rf
+ -print0 | xargs -0 rm -rfv
# Any remaining executables
find $(CURDIR) -type f -perm /u+x,g+x,o+x -exec file -i '{}' \; \
| grep -e application/x-executable \
- | cut -d ':' -f 1 | xargs rm -f
+ | cut -d ':' -f 1 | xargs rm -fv
# Generated on build
- rm -f debian/shlibs.local
- rm -f debian/stamp-makefile-build-tools
-
-ifeq ($(vendor),Ubuntu)
- rm -rf po
-endif
+ rm -fv debian/shlibs.local
+ rm -fv debian/stamp-makefile-build-tools
override_dh_auto_install:
dh_auto_install -Smakefile -- INSTALL_ROOT=$(CURDIR)/debian/tmp/
# Remove libtool-like files
- rm -f debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/*.la
+ rm -fv debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/*.la
# Ship private headers - ugly hack to build Qt Creator QML Designer
cd $(CURDIR)/include && rsync -aR QtCore/private \
@@ -323,20 +316,20 @@ override_dh_auto_install:
debian/qt4-qtconfig/usr/share/pixmaps/qtconfig-qt4.png
# QTBUG-12159 workaround
- rm -f debian/tmp//usr/share/qt4/mkspecs/modules/qt_webkit_version.pri
+ rm -fv debian/tmp//usr/share/qt4/mkspecs/modules/qt_webkit_version.pri
# Remove phonon development files
- rm -f debian/tmp/usr/lib/*/libphonon.la
- rm -f debian/tmp/usr/lib/*/libphonon.prl
- rm -f debian/tmp/usr/lib/*/libphonon.so
- rm -f debian/tmp/usr/lib/*/pkgconfig/phonon.pc
- rm -rf debian/tmp/usr/include/qt4/phonon
+ rm -fv debian/tmp/usr/lib/*/libphonon.la
+ rm -fv debian/tmp/usr/lib/*/libphonon.prl
+ rm -fv debian/tmp/usr/lib/*/libphonon.so
+ rm -fv debian/tmp/usr/lib/*/pkgconfig/phonon.pc
+ rm -rfv debian/tmp/usr/include/qt4/phonon
# And the gstreamer backend.
- rm -f debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/qt4/plugins/phonon_backend/libphonon_gstreamer.so
+ rm -fv debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/qt4/plugins/phonon_backend/libphonon_gstreamer.so
# Remove the embedded jquery library. We will later link to the one provided
# by the libjs-jquery package.
- rm -f debian/tmp/usr/share/qt4/doc/html/scripts/jquery.js
+ rm -fv debian/tmp/usr/share/qt4/doc/html/scripts/jquery.js
# Add a configuration for qtchooser
mkdir -p $(CURDIR)/debian/tmp/usr/share/qtchooser
@@ -361,7 +354,7 @@ override_dh_auto_install:
-o -name .obj\* \
-o -name .pch \
-o -name .rcc \
- \) -print0 | xargs -0 rm -rf
+ \) -print0 | xargs -0 rm -rfv
# Remove bogus exec bits from some data files in mkspecs, docs, examples
# and demos
@@ -370,14 +363,6 @@ override_dh_auto_install:
-regex '.*\.\(app\|conf\|cpp\|h\|js\|php\|png\|pro\|xml\|xsl\)$$' \
-exec chmod a-x {} \;
-ifeq ($(vendor),Ubuntu)
- # Create .pot file
- ln -s MessagesQt.sh debian/Messages.sh
- mkdir po
- cd debian; qtcopydir=.. podir=../po extract-messages.sh
- rm -f debian/Message.sh
-endif
-
override_dh_install:
dh_install --fail-missing
@@ -415,5 +400,12 @@ override_dh_builddeb:
prune-nonfree:
# Delete RFCs.
find \( -name rfc????.txt \) -print -delete
+ # Delete files that contain minified javascript libs without source
+ # In it's preferred form of modification.
+ rm -fv tests/benchmarks/script/sunspider/tests/string-unpack-code.js
+ rm -fv doc/html/scripts/jquery.js
+ rm -fv doc/src/template/scripts/jquery.js
+ rm -fv tools/qdoc3/doc/config/scripts/jquery.js
+ rm -fv examples/webkit/fancybrowser/jquery.min.js
.PHONY: override_dh_auto_test