summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 8 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 4ec8759..d791fbe 100755
--- a/debian/rules
+++ b/debian/rules
@@ -53,7 +53,14 @@ override_dh_auto_install-indep:
override_dh_missing:
dh_missing --fail-missing
-override_dh_auto_test:
+override_dh_auto_test-arch:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ -cd obj-$(DEB_HOST_GNU_TYPE); \
+ xvfb-run -a -s "-screen 0 1024x768x24 +extension RANDR +extension RENDER +extension GLX" \
+ ctest --output-on-failure
+endif
+
+override_dh_auto_test-indep:
# Do not attempt to run anything to make build-indep work
override_dh_strip: