summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDmitry Shachnev <mitya57@gmail.com>2016-10-28 15:39:13 +0300
committerDmitry Shachnev <mitya57@gmail.com>2016-10-28 15:39:13 +0300
commit3a7daa8f0e96f88c015c8847f1060c88d0880b69 (patch)
treebff8518da5f1d26b973a4a7d13b8916a2ce5a26b /debian/rules
parentc08a17fd7636399ff14fce300cfc4a417c37cc74 (diff)
downloadqtbase-3a7daa8f0e96f88c015c8847f1060c88d0880b69.tar.gz
Configure with -no-use-gold-linker on i386.
To work around build failures of qtscript and qtgraphicaleffects. See binutils bug #842304.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 5 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 434624d..2a9a796 100755
--- a/debian/rules
+++ b/debian/rules
@@ -59,6 +59,11 @@ ifneq ($(DEB_HOST_ARCH_OS),$(findstring $(DEB_HOST_ARCH_OS), linux kfreebsd))
extra_configure_opts += -no-eglfs
endif
+# https://bugs.debian.org/842304
+ifeq ($(DEB_HOST_ARCH),i386)
+ extra_configure_opts += -no-use-gold-linker
+endif
+
# Compile without sse2 support on i386
# Do not use pre compiled headers in order to be able to rebuild the gui
# submodule.