summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorLisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>2016-05-22 12:46:30 -0300
committerLisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>2016-05-22 12:46:30 -0300
commitca264e05eab3ce6b72ccd8e32528e7fbbc984ee2 (patch)
tree2cf33789176c1ba91f2cf7d4adf6323969054030 /debian/rules
parentd55bbecfcbd4282fc2ade7b14527d6955e2cc854 (diff)
parentbe8d0e7bb7f6bb4105129196f193e0dd45deac47 (diff)
downloadqtbase-ca264e05eab3ce6b72ccd8e32528e7fbbc984ee2.tar.gz
merge master into experimental.Merge branch 'master' into experimental
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 1 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index d704c33..a957cf5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -249,16 +249,8 @@ endif
find $(CURDIR)/debian/tmp/usr/lib/*/pkgconfig -type f -name '*.pc' \
-exec perl -pi -e "s, -L$(CURDIR)/?\S+,,g" {} \;
- # Add a configuration for qtchooser
- mkdir -p $(CURDIR)/debian/tmp/usr/share/qtchooser
- echo "/usr/lib/$(DEB_HOST_MULTIARCH)/qt5/bin" > $(CURDIR)/debian/tmp/usr/share/qtchooser/qt5-$(DEB_HOST_MULTIARCH).conf
- echo "/usr/lib/$(DEB_HOST_MULTIARCH)" >> $(CURDIR)/debian/tmp/usr/share/qtchooser/qt5-$(DEB_HOST_MULTIARCH).conf
-
- # Ship 5.conf and qt5.conf for this arch, and a default.conf.
- # 5.conf makes calling qtchooser prettier.
+ # Configuration file for qt5-default package
mkdir -p $(CURDIR)/debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/qtchooser
- ln -s /usr/share/qtchooser/qt5-$(DEB_HOST_MULTIARCH).conf $(CURDIR)/debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/qtchooser/5.conf
- ln -s /usr/share/qtchooser/qt5-$(DEB_HOST_MULTIARCH).conf $(CURDIR)/debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/qtchooser/qt5.conf
ln -s /usr/share/qtchooser/qt5-$(DEB_HOST_MULTIARCH).conf $(CURDIR)/debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/qtchooser/default.conf
# Remove leftover directories