summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorJochen Friedrich <jochen@scram.de>2009-12-15 13:54:19 +0000
committerJochen Friedrich <jochen@scram.de>2009-12-15 13:54:19 +0000
commit3b5d59e715642b9b22d793994059942380b08f6a (patch)
tree11bfceafca97fcce64db6be4286db5786d6e01ed /debian/patches
parent69fadc65b0c6033f5df9bb9379d5f5f13fe813fe (diff)
downloadpkg-net-snmp-3b5d59e715642b9b22d793994059942380b08f6a.tar.gz
Install all provided NET-SNMP MIBs.
git-svn-id: svn://svn.debian.org/pkg-net-snmp/trunk@325 db575a87-f10d-0410-9662-f1d5ac62e4ba
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/03_makefiles.patch44
1 files changed, 12 insertions, 32 deletions
diff --git a/debian/patches/03_makefiles.patch b/debian/patches/03_makefiles.patch
index 422cbae..3cc21fe 100644
--- a/debian/patches/03_makefiles.patch
+++ b/debian/patches/03_makefiles.patch
@@ -1,7 +1,7 @@
Index: net-snmp-5.4.2.1/local/Makefile.in
===================================================================
---- net-snmp-5.4.2.1.orig/local/Makefile.in 2009-11-06 17:21:05.000000000 +0100
-+++ net-snmp-5.4.2.1/local/Makefile.in 2009-11-06 17:25:10.000000000 +0100
+--- net-snmp-5.4.2.1.orig/local/Makefile.in 2009-12-14 18:40:54.000000000 +0100
++++ net-snmp-5.4.2.1/local/Makefile.in 2009-12-14 18:42:44.000000000 +0100
@@ -100,7 +100,7 @@
mib2c.made: $(srcdir)/mib2c
@@ -13,8 +13,8 @@ Index: net-snmp-5.4.2.1/local/Makefile.in
fi
Index: net-snmp-5.4.2.1/Makefile.top
===================================================================
---- net-snmp-5.4.2.1.orig/Makefile.top 2009-11-06 17:21:05.000000000 +0100
-+++ net-snmp-5.4.2.1/Makefile.top 2009-11-06 17:25:41.000000000 +0100
+--- net-snmp-5.4.2.1.orig/Makefile.top 2009-12-14 18:40:54.000000000 +0100
++++ net-snmp-5.4.2.1/Makefile.top 2009-12-14 18:42:44.000000000 +0100
@@ -24,8 +24,9 @@
man5dir = $(mandir)/man5
man8dir = $(mandir)/man8
@@ -28,15 +28,17 @@ Index: net-snmp-5.4.2.1/Makefile.top
Index: net-snmp-5.4.2.1/mibs/Makefile.in
===================================================================
---- net-snmp-5.4.2.1.orig/mibs/Makefile.in 2009-11-06 17:21:05.000000000 +0100
-+++ net-snmp-5.4.2.1/mibs/Makefile.in 2009-11-06 17:25:10.000000000 +0100
-@@ -13,53 +13,33 @@
+--- net-snmp-5.4.2.1.orig/mibs/Makefile.in 2009-12-14 18:40:54.000000000 +0100
++++ net-snmp-5.4.2.1/mibs/Makefile.in 2009-12-14 18:48:11.000000000 +0100
+@@ -13,53 +13,24 @@
OTHERUNINSTALL=mibsuninstall
-V1MIBS = RFC1155-SMI.txt RFC1213-MIB.txt RFC-1215.txt
+NETSNMPMIBS = NET-SNMP-TC NET-SNMP-MIB NET-SNMP-AGENT-MIB \
-+ NET-SNMP-EXAMPLES-MIB NET-SNMP-EXTEND-MIB
++ NET-SNMP-EXAMPLES-MIB NET-SNMP-EXTEND-MIB \
++ NET-SNMP-MONITOR-MIB NET-SNMP-SYSTEM-MIB \
++ NET-SNMP-VACM-MIB
-V2MIBS = SNMPv2-CONF.txt SNMPv2-SMI.txt SNMPv2-TC.txt SNMPv2-TM.txt \
- SNMPv2-MIB.txt
@@ -81,9 +83,6 @@ Index: net-snmp-5.4.2.1/mibs/Makefile.in
+EXTRAMIBS = GNOME-SMI LM-SENSORS-MIB
+
+MIBS = $(NETSNMPMIBS) $(UCDMIBS) $(EXTRAMIBS)
-+
-+HELPERS = Makefile.mib ianalist rfclist rfcmibs.diff
-+BINHELPERS = mibfetch smistrip
all: standardall
@@ -94,32 +93,13 @@ Index: net-snmp-5.4.2.1/mibs/Makefile.in
+ @for i in $(MIBS); do \
+ $(INSTALL_DATA) $(srcdir)/$$i.txt $(INSTALL_PREFIX)$(mibdir)/$$i ; \
+ echo "install: installed $$i.txt in $(INSTALL_PREFIX)$(mibdir)/$$i" ; \
-+ done
-+ @for i in $(HELPERS); do \
-+ $(INSTALL_DATA) $(srcdir)/$$i $(INSTALL_PREFIX)$(datadir)/mibs ; \
-+ echo "install: installed $$i in $(INSTALL_PREFIX)$(datadir)/mibs" ; \
-+ done
-+ @for i in $(BINHELPERS) ; do \
-+ $(INSTALL) $(srcdir)/$$i $(INSTALL_PREFIX)$(datadir)/mibs ; \
-+ echo "install: installed $$i in $(INSTALL_PREFIX)$(datadir)/mibs" ; \
done
mibsuninstall: installdirs
-@@ -67,6 +47,10 @@
- rm -f $(INSTALL_PREFIX)$(mibdir)/$$i ; \
- echo "removed $$i from $(INSTALL_PREFIX)$(mibdir)" ; \
- done
-+ @for i in $(HELPERS) $(BINHELPERS) ; do \
-+ rm -f $(INSTALL_PREFIX)$(mibdir)/$$i ; \
-+ echo "removed $$i from $(INSTALL_PREFIX)$(datadir)/mibs" ; \
-+ done
-
- installdirs:
- @$(SHELL) $(srcdir)/../mkinstalldirs $(INSTALL_PREFIX)$(mibdir)
Index: net-snmp-5.4.2.1/Makefile.in
===================================================================
---- net-snmp-5.4.2.1.orig/Makefile.in 2009-11-06 17:21:05.000000000 +0100
-+++ net-snmp-5.4.2.1/Makefile.in 2009-11-06 17:25:10.000000000 +0100
+--- net-snmp-5.4.2.1.orig/Makefile.in 2009-12-14 18:40:54.000000000 +0100
++++ net-snmp-5.4.2.1/Makefile.in 2009-12-14 18:42:44.000000000 +0100
@@ -156,7 +156,7 @@
#
# override LD_RUN_PATH to avoid dependencies on the build directory