summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorabou.almontacir@sfr.fr <abou.almontacir@sfr.fr@b4165226-8c1b-0410-80e1-07324e54c907>2013-06-21 20:02:34 +0000
committerabou.almontacir@sfr.fr <abou.almontacir@sfr.fr@b4165226-8c1b-0410-80e1-07324e54c907>2013-06-21 20:02:34 +0000
commit382741226d4ee4097a70c2080c78dde6d1cdaebd (patch)
tree7f8c4a8354ac7f82e9be14c8ea7848d24809bf53 /debian/rules
parentae734b5f7c4be30a4ec74304845ab3e047c0d280 (diff)
downloadfpc-382741226d4ee4097a70c2080c78dde6d1cdaebd.tar.gz
Pass "-z relro" to linker to remove lintian warning.
git-svn-id: https://bollin.googlecode.com/svn/fpc/trunk@5306 b4165226-8c1b-0410-80e1-07324e54c907
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 1721f01b..2807d5f4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -126,6 +126,8 @@ DEB_BUILD_MULTIARCH ?=$(shell dpkg-architecture -qDEB_BUILD_MULTIARCH)
FPMAKE_BUILDOPTS=FPMAKE_SKIP_CONFIG='-n @${CURDIR}/${DEB_BUILD_FPC_OPT}'
+LDFLAGS=$(shell dpkg-buildflags --get LDFLAGS | sed -e 's/-Wl,//g' -e 's/,/ /g')
+
#export DH_VERBOSE=1
###################
@@ -418,8 +420,10 @@ fpcsrc/utils/fpcm/Makefile:fpcsrc/utils/fpcm/Makefile.fpc
${DEB_BUILD_FPC_OPT}:
echo '# FPC configuration file for build system tools' > $@
+ echo '-k${LDFLAGS}' >> $@
echo '-Fl/usr/lib/${DEB_BUILD_MULTIARCH}' >> $@
${DEB_HOST_FPC_OPT}:
echo '# FPC configuration file for host system applications' > $@
+ echo '-k${LDFLAGS}' >> $@
echo '-Fl/usr/lib/${DEB_HOST_MULTIARCH}' >> $@