summaryrefslogtreecommitdiff
path: root/debian/control.in
diff options
context:
space:
mode:
Diffstat (limited to 'debian/control.in')
-rw-r--r--debian/control.in43
1 files changed, 21 insertions, 22 deletions
diff --git a/debian/control.in b/debian/control.in
index 27ecc31..211a6cf 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -2,29 +2,28 @@ Source: @PVER@
Section: python
Priority: optional
Maintainer: Matthias Klose <doko@debian.org>
-Build-Depends: debhelper (>= 5), @bd_dpkgdev@
- gcc (>= 4:4.9.2),
+Build-Depends: debhelper (>= 9), @bd_dpkgdev@ @bd_gcc@
quilt, autoconf, autotools-dev,
lsb-release, sharutils,
- libreadline-dev, libtinfo-dev, libncursesw5-dev (>= 5.3), @bd_gcc@
- tk-dev, blt-dev (>= 2.4z), libssl-dev,
+ libreadline-dev, libtinfo-dev, libncursesw5-dev (>= 5.3),
+ tk-dev, blt-dev (>= 2.4z), libssl-dev (>= 1.1.1),
zlib1g-dev, libbz2-dev,
libexpat1-dev,
- libbluetooth-dev [linux-any],
+ libbluetooth-dev [linux-any]@pf_bluetooth@,
locales [!armel !avr32 !hppa !ia64 !mipsel],
libsqlite3-dev, libffi-dev (>= 3.0.5) [!or1k !avr32],
libgpm2 [linux-any],
- mime-support, netbase, net-tools, bzip2,
- libdb-dev (<< 1:6.0), libgdbm-dev, python@bd_qual@, help2man,
- xvfb, xauth
-Build-Depends-Indep: python-sphinx
+ mime-support, netbase, net-tools, bzip2, time,
+ libdb-dev (<< 1:6.0), libgdbm-dev, help2man,
+ xvfb <!nocheck>, xauth <!nocheck>
+Build-Depends-Indep: python3-sphinx
Build-Conflicts: tcl8.4-dev, tk8.4-dev,
@PVER@-xml, python-xml,
autoconf2.13, python-cxx-dev,
hardening-wrapper
-Standards-Version: 3.9.6
-Vcs-Browser: https://code.launchpad.net/~doko/python/pkg@VER@-debian
-Vcs-Bzr: http://bazaar.launchpad.net/~doko/python/pkg@VER@-debian
+Standards-Version: 4.4.1
+Vcs-Browser: https://salsa.debian.org/cpython-team/python2
+Vcs-Git: https://salsa.debian.org/cpython-team/python2.git
XS-Testsuite: autopkgtest
Package: @PVER@
@@ -45,10 +44,10 @@ Package: lib@PVER@-stdlib
Architecture: any
Multi-Arch: same
Priority: @PRIO@
-Depends: lib@PVER@-minimal (= ${binary:Version}), mime-support, ${shlibs:Depends}, ${misc:Depends}
+Depends: lib@PVER@-minimal (= ${binary:Version}), libssl1.1 (>= 1.1.1), mime-support, ${shlibs:Depends}, ${misc:Depends}
Provides: @PVER@-cjkcodecs, @PVER@-ctypes, @PVER@-elementtree, @PVER@-celementtree, @PVER@-wsgiref, @PVER@-profiler, @PVER@-argparse, python-argparse
-Replaces: @PVER@ (<< 2.7.5-0~)
-Breaks: python-urllib3 (<< 1.9.1-3)
+Replaces: @PVER@ (<< 2.7.5-0~), lib@PVER@-testsuite (<< 2.7.13-4)
+Breaks: python-urllib3 (<< 1.9.1-3), ${pyfpe:Breaks}
Description: Interactive high-level object-oriented language (standard library, version @VER@)
Python is a high-level, interactive, object-oriented language. Its @VER@ version
includes an extensive class library with lots of goodies for
@@ -91,7 +90,7 @@ Architecture: any
Multi-Arch: same
Section: libs
Priority: @PRIO@
-Pre-Depends: multiarch-support
+Pre-Depends: ${misc:Pre-Depends}
Depends: lib@PVER@-stdlib (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends}
Replaces: @PVER@ (<< 2.6)
Description: Shared Python runtime library (version @VER@)
@@ -104,7 +103,8 @@ Description: Shared Python runtime library (version @VER@)
Package: @PVER@-examples
Architecture: all
-Depends: @PVER@ (>= ${source:Version}), ${misc:Depends}
+Multi-Arch: foreign
+Depends: @PVER@:any (>= ${source:Version}), ${misc:Depends}
Description: Examples for the Python language (v@VER@)
Examples, Demos and Tools for Python (v@VER@). These are files included in
the upstream Python distribution (v@VER@).
@@ -126,7 +126,7 @@ Package: lib@PVER@-dev
Section: libdevel
Architecture: any
Multi-Arch: same
-Pre-Depends: multiarch-support
+Pre-Depends: ${misc:Pre-Depends}
Depends: lib@PVER@-stdlib (= ${binary:Version}), lib@PVER@ (= ${binary:Version}), libexpat1-dev, ${shlibs:Depends}, ${misc:Depends}
Replaces: @PVER@ (<< 2.7-3), @PVER@-dev (<< 2.7.3-10), @PVER@-minimal (<< 2.7.3-10)
Recommends: libc6-dev | libc-dev
@@ -164,7 +164,8 @@ Description: IDE for Python (v@VER@) using Tkinter
Package: @PVER@-doc
Section: doc
Architecture: all
-Depends: libjs-jquery, ${misc:Depends}
+Multi-Arch: foreign
+Depends: libjs-jquery, libjs-underscore, ${misc:Depends}
Suggests: @PVER@
Description: Documentation for the high-level object-oriented language Python (v@VER@)
These is the official set of documentation for the interactive high-level
@@ -186,7 +187,6 @@ Package: @PVER@-dbg
Section: debug
Architecture: any
Multi-Arch: allowed
-Priority: extra
Depends: @PVER@ (= ${binary:Version}), lib@PVER@-dbg (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends}
Suggests: python-gdbm-dbg, python-tk-dbg
Description: Debug Build of the Python Interpreter (version @VER@)
@@ -203,8 +203,7 @@ Package: lib@PVER@-dbg
Section: debug
Architecture: any
Multi-Arch: same
-Priority: extra
-Pre-Depends: multiarch-support
+Pre-Depends: ${misc:Pre-Depends}
Depends: lib@PVER@-stdlib (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends}
Suggests: @PVER@-gdbm-dbg, @PVER@-tk-dbg
Replaces: @PVER@-dbg (<< 2.7.3-10)