summaryrefslogtreecommitdiff
path: root/debian/patches/dyson.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/dyson.patch')
-rw-r--r--debian/patches/dyson.patch67
1 files changed, 16 insertions, 51 deletions
diff --git a/debian/patches/dyson.patch b/debian/patches/dyson.patch
index 2a86648..8526be3 100644
--- a/debian/patches/dyson.patch
+++ b/debian/patches/dyson.patch
@@ -1,8 +1,8 @@
-Index: python3.6-3.6.3~rc1/configure.ac
+Index: python3.7.git/configure.ac
===================================================================
---- python3.6-3.6.3~rc1.orig/configure.ac
-+++ python3.6-3.6.3~rc1/configure.ac
-@@ -466,13 +466,6 @@ case $ac_sys_system/$ac_sys_release in
+--- python3.7.git.orig/configure.ac
++++ python3.7.git/configure.ac
+@@ -465,13 +465,6 @@ case $ac_sys_system/$ac_sys_release in
# Marc Recht
NetBSD/1.5 | NetBSD/1.5.* | NetBSD/1.6 | NetBSD/1.6.* | NetBSD/1.6@<:@A-S@:>@)
define_xopen_source=no;;
@@ -16,7 +16,7 @@ Index: python3.6-3.6.3~rc1/configure.ac
# On UnixWare 7, u_long is never defined with _XOPEN_SOURCE,
# but used in /usr/include/netinet/tcp.h. Reported by Tim Rice.
# Reconfirmed for 7.1.4 by Martin v. Loewis.
-@@ -525,8 +518,6 @@ then
+@@ -520,8 +513,6 @@ then
# definition of _XOPEN_SOURCE_EXTENDED and _POSIX_C_SOURCE, or else
# several APIs are not declared. Since this is also needed in some
# cases for HP-UX, we define it globally.
@@ -25,7 +25,7 @@ Index: python3.6-3.6.3~rc1/configure.ac
AC_DEFINE(_POSIX_C_SOURCE, 200809L, Define to activate features from IEEE Stds 1003.1-2008)
fi
-@@ -861,6 +852,14 @@ cat >> conftest.c <<EOF
+@@ -866,6 +857,14 @@ cat >> conftest.c <<EOF
i386-gnu
#elif defined(__APPLE__)
darwin
@@ -40,7 +40,7 @@ Index: python3.6-3.6.3~rc1/configure.ac
#else
# error unknown platform triplet
#endif
-@@ -1137,17 +1136,7 @@ if test $enable_shared = "yes"; then
+@@ -1131,17 +1130,7 @@ if test $enable_shared = "yes"; then
LDLIBRARY='libpython$(LDVERSION).dll.a'
DLLLIBRARY='libpython$(LDVERSION).dll'
;;
@@ -59,22 +59,7 @@ Index: python3.6-3.6.3~rc1/configure.ac
LDLIBRARY='libpython$(LDVERSION).so'
BLDLIBRARY='-L. -lpython$(LDVERSION)'
RUNSHARED=LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
-@@ -2436,14 +2425,6 @@ then
- ;;
- IRIX/5*) LDSHARED="ld -shared";;
- IRIX*/6*) LDSHARED="ld ${SGI_ABI} -shared -all";;
-- SunOS/5*)
-- if test "$GCC" = "yes" ; then
-- LDSHARED='$(CC) -shared'
-- LDCXXSHARED='$(CXX) -shared'
-- else
-- LDSHARED='$(CC) -G'
-- LDCXXSHARED='$(CXX) -G'
-- fi ;;
- hp*|HP*)
- if test "$GCC" = "yes" ; then
- LDSHARED='$(CC) -shared'
-@@ -2510,7 +2491,7 @@ then
+@@ -2610,7 +2599,7 @@ then
BLDSHARED="$LDSHARED"
fi
;;
@@ -82,37 +67,17 @@ Index: python3.6-3.6.3~rc1/configure.ac
+ Linux*|GNU*|QNX*|SunOS*)
LDSHARED='$(CC) -shared -Wl,-O1 -Wl,-Bsymbolic-functions'
LDCXXSHARED='$(CXX) -shared -Wl,-O1 -Wl,-Bsymbolic-functions';;
- BSD/OS*/4*)
-@@ -2569,18 +2550,12 @@ AC_MSG_CHECKING(CCSHARED)
- if test -z "$CCSHARED"
- then
- case $ac_sys_system/$ac_sys_release in
-- SunOS*) if test "$GCC" = yes;
-- then CCSHARED="-fPIC";
-- elif test `uname -p` = sparc;
-- then CCSHARED="-xcode=pic32";
-- else CCSHARED="-Kpic";
-- fi;;
- hp*|HP*) if test "$GCC" = yes;
- then CCSHARED="-fPIC";
- else CCSHARED="+z";
- fi;;
- Linux-android*) ;;
-- Linux*|GNU*) CCSHARED="-fPIC";;
-+ Linux*|GNU*|SunOS*) CCSHARED="-fPIC";;
- BSD/OS*/4*) CCSHARED="-fpic";;
- FreeBSD*|NetBSD*|OpenBSD*|DragonFly*) CCSHARED="-fPIC";;
- OpenUNIX*|UnixWare*)
-@@ -2612,7 +2587,7 @@ then
+ FreeBSD*)
+@@ -2703,7 +2692,7 @@ then
+ LINKFORSHARED="-Wl,-E -Wl,+s";;
# LINKFORSHARED="-Wl,-E -Wl,+s -Wl,+b\$(BINLIBDEST)/lib-dynload";;
- BSD/OS/4*) LINKFORSHARED="-Xlinker -export-dynamic";;
Linux-android*) LINKFORSHARED="-pie -Xlinker -export-dynamic";;
- Linux*|GNU*) LINKFORSHARED="-Xlinker -export-dynamic -Wl,-O1 -Wl,-Bsymbolic-functions";;
+ Linux*|GNU*|SunOS*) LINKFORSHARED="-Xlinker -export-dynamic -Wl,-O1 -Wl,-Bsymbolic-functions";;
# -u libsys_s pulls in all symbols in libsys
Darwin/*)
LINKFORSHARED="$extra_undefs -framework CoreFoundation"
-@@ -2635,13 +2610,6 @@ then
+@@ -2726,13 +2715,6 @@ then
then
LINKFORSHARED="-Wl,--export-dynamic"
fi;;
@@ -126,7 +91,7 @@ Index: python3.6-3.6.3~rc1/configure.ac
CYGWIN*)
if test $enable_shared = "no"
then
-@@ -2692,9 +2660,9 @@ AC_MSG_RESULT($SHLIBS)
+@@ -2783,9 +2765,9 @@ AC_MSG_RESULT($SHLIBS)
# checks for libraries
@@ -137,9 +102,9 @@ Index: python3.6-3.6.3~rc1/configure.ac
+AC_SEARCH_LIBS(dl, dlopen)
+AC_SEARCH_LIBS(shl_load, dld) # Dynamic linking for HP-UX
- # only check for sem_init if thread support is requested
- if test "$with_threads" = "yes" -o -z "$with_threads"; then
-@@ -4654,7 +4622,7 @@ AC_MSG_RESULT($SOABI)
+ # checks for uuid.h location
+ AC_CHECK_HEADERS([uuid/uuid.h uuid.h])
+@@ -4753,7 +4735,7 @@ AC_MSG_RESULT($SOABI)
AC_SUBST(EXT_SUFFIX)
case $ac_sys_system in