summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorIvo De Decker <ivodd@debian.org>2015-03-07 12:30:41 +0100
committerIvo De Decker <ivodd@debian.org>2015-03-07 12:30:41 +0100
commit3890472c9bb1e290e6438e8b43df2c505a0ea79d (patch)
tree35907b4a74bcf4d3f7022701a3bc92fda9fe7355 /debian
parente244bab1767c9b684d7d79ca24a3e389a2c9bf53 (diff)
downloadsamba-3890472c9bb1e290e6438e8b43df2c505a0ea79d.tar.gz
Add samba.preinst to temporarily deactivate the old qtsmbstatusd initscript
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog9
-rw-r--r--debian/samba.preinst18
2 files changed, 27 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 40abb9c028..b44ce231c0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+samba (2:4.1.17+dfsg-2) UNRELEASED; urgency=medium
+
+ * Add samba.preinst to temporarily deactivate the old qtsmbstatusd
+ initscript which has dependencies incompatible with the new samba
+ initscript. This will ensure a clean upgrade path for samba if the
+ qtsmbstatus-server package was installed previously. (Closes: #779666)
+
+ -- Andreas Beckmann <anbe@debian.org> Wed, 04 Mar 2015 12:12:57 +0100
+
samba (2:4.1.17+dfsg-1) unstable; urgency=high
* New upstream release. Fixes:
diff --git a/debian/samba.preinst b/debian/samba.preinst
new file mode 100644
index 0000000000..ae8cfaac92
--- /dev/null
+++ b/debian/samba.preinst
@@ -0,0 +1,18 @@
+#!/bin/sh
+set -e
+
+# Deactivate the old qtsmbstatusd initscript that has dependencies
+# incompatible with the new samba initscript. This will allow to
+# configure the new samba package and qtsmbstatus-server afterwards.
+if [ "$1" = "upgrade" ] || [ "$1" = "install" ]; then
+ if [ -x "/etc/init.d/qtsmbstatusd" ]; then
+ version=$(dpkg-query -f '${Config-Version} ${Version}' -W qtsmbstatus-server 2>/dev/null | awk '{ print $1 }')
+ if dpkg --compare-versions "$version" lt-nl "2.2.1-3~" ; then
+ echo "Deactivating qtsmbstatusd temporarily..."
+ invoke-rc.d qtsmbstatusd stop
+ update-rc.d -f qtsmbstatusd remove
+ fi
+ fi
+fi
+
+#DEBHELPER#