summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2010-11-18 07:34:11 +0100
committerMichael Biebl <biebl@debian.org>2010-11-18 07:38:41 +0100
commit2df4c11367815b254b17750ccf6f4421ec610b47 (patch)
tree00ce3caffe088be38c63fe282af2f46873ba6189 /debian
parente2437b15e2ddf8c648e8d7be7bd8af7480b5f791 (diff)
downloadavahi-2df4c11367815b254b17750ccf6f4421ec610b47.tar.gz
Move from cdbs to dh
- Drop Build-Depends on cdbs. - Bump Build-Depends on debhelper to (>= 7.0.50~) for override targets. - Convert debian/rules to use dh. - Drop debian/clean-la.mk (merged into debian/rules).
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/clean-la.mk6
-rw-r--r--debian/control3
-rwxr-xr-xdebian/rules83
4 files changed, 49 insertions, 48 deletions
diff --git a/debian/changelog b/debian/changelog
index 3ba2407..8d0784f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,11 @@ avahi (0.6.28-1) UNRELEASED; urgency=low
* New upstream release.
* Remove debian/patches/02_avahi_client.patch, merged upstream.
+ * Move from cdbs to dh
+ - Drop Build-Depends on cdbs.
+ - Bump Build-Depends on debhelper to (>= 7.0.50~) for override targets.
+ - Convert debian/rules to use dh.
+ - Drop debian/clean-la.mk (merged into debian/rules).
-- Michael Biebl <biebl@debian.org> Thu, 18 Nov 2010 06:12:26 +0100
diff --git a/debian/clean-la.mk b/debian/clean-la.mk
deleted file mode 100644
index d62b417..0000000
--- a/debian/clean-la.mk
+++ /dev/null
@@ -1,6 +0,0 @@
-# makefile snippet for removing dependency_libs lines from .la files
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- for file in $(wildcard debian/$(cdbs_curpkg)/usr/lib/*.la); do \
- sed -i "/dependency_libs/ s/'.*'/''/" $$file ; \
- done
diff --git a/debian/control b/debian/control
index 68eaf81..7941842 100644
--- a/debian/control
+++ b/debian/control
@@ -6,8 +6,7 @@ Uploaders: Sjoerd Simons <sjoerd@debian.org>,
Sebastian Dröge <slomo@debian.org>,
Loic Minier <lool@dooz.org>,
Michael Biebl <biebl@debian.org>
-Build-Depends: debhelper (>= 7),
- cdbs (>= 0.4.43),
+Build-Depends: debhelper (>= 7.0.50~),
pkg-config,
python-support (>= 0.6),
libcap-dev (>= 1:2.16) [linux-any],
diff --git a/debian/rules b/debian/rules
index 742be33..ab7673c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,62 +1,65 @@
#!/usr/bin/make -f
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/autotools.mk
-include /usr/share/cdbs/1/rules/buildvars.mk
-include debian/clean-la.mk
+%:
+ dh $@
-# List any files which are not installed
-include /usr/share/cdbs/1/rules/utils.mk
-common-binary-post-install-arch:: list-missing
-
-# Ensure at build time that the library has no dependencies on undefined
-# symbols, and speed up loading.
-LDFLAGS += -Wl,-z,defs -Wl,-O1
-
-DEB_CONFIGURE_EXTRA_FLAGS += --enable-compat-libdns_sd \
- --disable-mono --disable-monodoc \
- --disable-gtk3
+DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
+DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
# Only enable the stack protector on certain archs
ifeq (,$(filter $(DEB_HOST_ARCH), powerpc s390 sparc amd64 i386 lpia))
- DEB_CONFIGURE_EXTRA_FLAGS += --disable-stack-protector
+ CONFFLAGS += --disable-stack-protector
endif
-
ifneq (linux,$(DEB_HOST_ARCH_OS))
- DEB_CONFIGURE_EXTRA_FLAGS += --disable-autoipd
+ CONFFLAGS += --disable-autoipd
endif
-DEB_UPDATE_RCD_PARAMS_avahi-daemon := start 14 2 3 4 5 . stop 86 0 1 6 .
-DEB_UPDATE_RCD_PARAMS_avahi-dnsconfd := start 16 2 3 4 5 . stop 84 0 1 6 .
+# Ensure at build time that the library has no dependencies on undefined
+# symbols, and speed up loading.
+LDFLAGS += -Wl,-z,defs -Wl,-O1
+
+override_dh_auto_configure:
+ dh_auto_configure -- $(CONFFLAGS) \
+ --enable-compat-libdns_sd \
+ --disable-mono --disable-monodoc \
+ --disable-gtk3
-DEB_INSTALL_DOCS_ALL += docs/README docs/NEWS
-common-build-arch::
+override_dh_auto_build:
+ dh_auto_build
# create an up to date PO template
cd po; intltool-update -p --verbose
-clean::
+override_dh_auto_clean:
+ dh_auto_clean
rm -f po/*.pot
-binary-install/avahi-discover::
- dh_pysupport -p$(cdbs_curpkg)
-
-binary-install/python-avahi::
- dh_pysupport -p$(cdbs_curpkg)
-
-install/avahi-autoipd::
- dh_installifupdown -p$(cdbs_curpkg)
-
-install/avahi-daemon::
- dh_installifupdown -p$(cdbs_curpkg)
+override_dh_auto_install:
+ dh_auto_install
install -D -o root -g root -m 755 debian/avahi-daemon.resolvconf \
- debian/$(cdbs_curpkg)/etc/resolvconf/update-libc.d/avahi-daemon
+ debian/avahi-daemon/etc/resolvconf/update-libc.d/avahi-daemon
install -D -o root -g root -m 755 debian/avahi-daemon-check-dns.sh \
- debian/$(cdbs_curpkg)/usr/lib/avahi/avahi-daemon-check-dns.sh
-
+ debian/avahi-daemon/usr/lib/avahi/avahi-daemon-check-dns.sh
ifeq (linux,$(DEB_HOST_ARCH_OS))
-common-install-impl::
- mv $(DEB_DESTDIR)/etc/dhcp/dhclient-exit-hooks.d/avahi-autoipd \
- $(DEB_DESTDIR)/etc/dhcp/dhclient-exit-hooks.d/zzz_avahi-autoipd
+ mv debian/tmp/etc/dhcp/dhclient-exit-hooks.d/avahi-autoipd \
+ debian/tmp/etc/dhcp/dhclient-exit-hooks.d/zzz_avahi-autoipd
endif
+ # cleanup dependency_libs from libtool .la files
+ for file in $(wildcard debian/tmp/usr/lib/*.la); do \
+ sed -i "/dependency_libs/ s/'.*'/''/" $$file ; \
+ done
+
+# List any files which are not installed
+override_dh_install:
+ dh_install --list-missing
+
+override_dh_installinit:
+ dh_installinit -pavahi-daemon -- start 14 2 3 4 5 . stop 86 0 1 6 .
+ dh_installinit -pavahi-dnsconfd -- start 16 2 3 4 5 . stop 84 0 1 6 .
+
+override_dh_installdocs:
+ dh_installdocs --all docs/NEWS docs/README
+
+override_dh_strip:
+ dh_strip --dbg-package=avahi-dbg