summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index bc2698cc..ad2ed299 100644
--- a/configure.in
+++ b/configure.in
@@ -292,7 +292,8 @@ AM_CONDITIONAL(USE_PARTED, [test x$use_parted = xyes])
#### gcc linker flags
-if test "x$GCC" = "xyes"; then
+if test "x$GCC" = "xyes" -a `uname -s` != SunOS; then
+ # This causes undefined symbols errors on Solaris
LDFLAGS="-Wl,--as-needed $LDFLAGS"
fi
@@ -747,7 +748,7 @@ esac
# OS specific libs
case "$host" in
*-*-solaris*)
- HALD_OS_LIBS="-lsysevent -lnvpair -ldevinfo"
+ HALD_OS_LIBS="-lsysevent -lnvpair -ldevinfo -lkstat -lcfgadm"
AC_SUBST(HALD_OS_LIBS)
;;
esac