summaryrefslogtreecommitdiff
path: root/libusb/Makefile.am
diff options
context:
space:
mode:
authorPeter Stuge <peter@stuge.se>2011-06-05 23:21:08 +0200
committerPeter Stuge <peter@stuge.se>2011-07-24 22:29:09 +0200
commit18db4813e844fc6929680afcc9b793abcb06876a (patch)
treedcc13f618727b7225b4664b99bfcecfee1c3ca83 /libusb/Makefile.am
parent5f30c81f66e8dd61f8eae16de548697708f9bd18 (diff)
downloadlibusb-18db4813e844fc6929680afcc9b793abcb06876a.tar.gz
libusb/Makefile.am: Correct threading files in libusb_1_0_la_SOURCES
Diffstat (limited to 'libusb/Makefile.am')
-rw-r--r--libusb/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/libusb/Makefile.am b/libusb/Makefile.am
index 78f49a1..0428830 100644
--- a/libusb/Makefile.am
+++ b/libusb/Makefile.am
@@ -19,19 +19,21 @@ endif
if OS_WINDOWS
OS_SRC = $(WINDOWS_USB_SRC)
-if !THREADS_POSIX
-OS_SRC += os/threads_windows.c
-endif
-
.rc.lo:
$(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(RC) $(RCFLAGS) -i $< -o $@
endif
+if THREADS_POSIX
+THREADS_SRC = os/threads_posix.h
+else
+THREADS_SRC = os/threads_windows.h os/threads_windows.c
+endif
+
libusb_1_0_la_CFLAGS = $(VISIBILITY_CFLAGS) $(AM_CFLAGS) $(THREAD_CFLAGS)
libusb_1_0_la_LDFLAGS = $(LTLDFLAGS)
libusb_1_0_la_SOURCES = libusbi.h core.c descriptor.c io.c sync.c $(OS_SRC) \
os/linux_usbfs.h os/darwin_usb.h os/windows_usb.h \
- os/threads_posix.h os/threads_windows.h \
+ $(THREADS_SRC) \
os/poll_posix.h os/poll_windows.h
hdrdir = $(includedir)/libusb-1.0