summaryrefslogtreecommitdiff
path: root/libusb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libusb/Makefile.am')
-rw-r--r--libusb/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/libusb/Makefile.am b/libusb/Makefile.am
index 2cd7021..1cb64b8 100644
--- a/libusb/Makefile.am
+++ b/libusb/Makefile.am
@@ -4,6 +4,7 @@ AUTOMAKE_OPTIONS = subdir-objects
lib_LTLIBRARIES = libusb-1.0.la
+SOLARIS_SRC = os/solaris_usb.c
POSIX_POLL_SRC = os/poll_posix.c
LINUX_USBFS_SRC = os/linux_usbfs.c
DARWIN_USB_SRC = os/darwin_usb.c
@@ -17,12 +18,17 @@ DIST_SUBDIRS =
EXTRA_DIST = $(LINUX_USBFS_SRC) $(DARWIN_USB_SRC) $(OPENBSD_USB_SRC) \
$(NETBSD_USB_SRC) $(WINDOWS_USB_SRC) $(WINCE_USB_SRC) \
$(POSIX_POLL_SRC) \
+ $(SOLARIS_SRC) \
os/threads_posix.c os/threads_windows.c \
os/linux_udev.c os/linux_netlink.c
dist-hook:
-cp -r os/haiku $(distdir)/os/haiku
+if OS_SOLARIS
+OS_SRC = $(SOLARIS_SRC) $(POSIX_POLL_SRC)
+endif
+
if OS_LINUX
if USE_UDEV