summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2011-02-23 12:00:34 -0500
committerDavid Zeuthen <davidz@redhat.com>2011-02-23 12:00:34 -0500
commit4746ff303b0803e928e5c88c961b8befc13fa57f (patch)
tree5b4ee40c836e7508fe988875d5eb8937bd1ed82b /configure.ac
parent78baa4742cf07fb04a9ecab24a068eca0e6ed547 (diff)
downloadpolkit-4746ff303b0803e928e5c88c961b8befc13fa57f.tar.gz
Bug 27253 – Use GOBJECT_INTROSPECTION_CHECK from gobject-introspection
https://bugs.freedesktop.org/show_bug.cgi?id=27253 Signed-off-by: David Zeuthen <davidz@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 2 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 4b7caff..5ed9894 100644
--- a/configure.ac
+++ b/configure.ac
@@ -379,25 +379,7 @@ case "$host_os" in
;;
esac
-# GObject introspection
-#
-AC_ARG_ENABLE([introspection],
- AS_HELP_STRING([--enable-introspection], [enable GObject introspection]),
- [], [enable_introspection=yes])
-if test "x$enable_introspection" = xyes; then
- PKG_CHECK_MODULES([INTROSPECTION], [gobject-introspection-1.0 >= 0.6.2])
- AC_DEFINE([ENABLE_INTROSPECTION], [1], [enable GObject introspection support])
- AC_SUBST([G_IR_SCANNER], [$($PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0)])
- AC_SUBST([G_IR_COMPILER], [$($PKG_CONFIG --variable=g_ir_compiler gobject-introspection-1.0)])
- AC_SUBST([G_IR_GENERATE], [$($PKG_CONFIG --variable=g_ir_generate gobject-introspection-1.0)])
- #AC_SUBST([GIRDIR], [$($PKG_CONFIG --variable=girdir gobject-introspection-1.0)])
- #AC_SUBST([GIRTYPELIBDIR], [$($PKG_CONFIG --variable=typelibdir gobject-introspection-1.0)])
- GIRDIR=${datadir}/gir-1.0
- GIRTYPELIBDIR=${libdir}/girepository-1.0
- AC_SUBST(GIRDIR)
- AC_SUBST(GIRTYPELIBDIR)
-fi
-AM_CONDITIONAL([ENABLE_INTROSPECTION], [test "x$enable_introspection" = xyes])
+GOBJECT_INTROSPECTION_CHECK([0.6.2])
AC_ARG_ENABLE([examples],
AS_HELP_STRING([--enable-examples], [Build the example programs]),,
@@ -458,7 +440,7 @@ echo "
cflags: ${CFLAGS}
cppflags: ${CPPFLAGS}
xsltproc: ${XSLTPROC}
- introspection: ${enable_introspection}
+ introspection: ${found_introspection}
Distribution/OS: ${with_os_type}
authentication framework: ${POLKIT_AUTHFW}