summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Zeuthen <davidz@redhat.com>2012-05-23 15:53:35 -0400
committerDavid Zeuthen <davidz@redhat.com>2012-05-23 15:53:35 -0400
commitb8f326194efab5feac819079ca9abb0b9f477103 (patch)
treed50949adef8620cdea7c97e8e992ce8418e0c063 /configure.ac
parent1724ece5c7b5a9f70969fd88e1a2dede8936e768 (diff)
downloadpolkit-b8f326194efab5feac819079ca9abb0b9f477103.tar.gz
Rename --enable-systemd to --enable-libsystemd-login
It's useful to be more specific because we also want an option to install a systemd .service file which you may not want even if you are using libsystemd-login... Signed-off-by: David Zeuthen <davidz@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 17 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 7b7f3eb..2712e19 100644
--- a/configure.ac
+++ b/configure.ac
@@ -152,33 +152,33 @@ if test "x$GCC" = "xyes"; then
fi
dnl ---------------------------------------------------------------------------
-dnl - Select wether to use systemd or ConsoleKit for session tracking
+dnl - Select wether to use libsystemd-login or ConsoleKit for session tracking
dnl ---------------------------------------------------------------------------
-have_systemd=no
+have_libsystemd_login=no
SESSION_TRACKING=ConsoleKit
-AC_ARG_ENABLE([systemd],
- AS_HELP_STRING([--enable-systemd[=@<:@auto/yes/no@:>@]], [Use systemd (auto/yes/no)]),
- [enable_systemd=$enableval],
- [enable_systemd=auto])
-if test "$enable_systemd" != "no"; then
- PKG_CHECK_MODULES(SYSTEMD,
+AC_ARG_ENABLE([libsystemd-login],
+ AS_HELP_STRING([--enable-libsystemd-login[=@<:@auto/yes/no@:>@]], [Use libsystemd-login (auto/yes/no)]),
+ [enable_libsystemd_login=$enableval],
+ [enable_libsystemd_login=auto])
+if test "$enable_libsystemd_login" != "no"; then
+ PKG_CHECK_MODULES(LIBSYSTEMD_LOGIN,
[libsystemd-login],
- have_systemd=yes,
- have_systemd=no)
- if test "$have_systemd" = "yes"; then
- SESSION_TRACKING=systemd
+ have_libsystemd_login=yes,
+ have_libsystemd_login=no)
+ if test "$have_libsystemd_login" = "yes"; then
+ SESSION_TRACKING=libsystemd-login
else
- if test "$enable_systemd" = "yes"; then
- AC_MSG_ERROR([systemd support requested but libsystemd-login1 library not found])
+ if test "$enable_libsystemd_login" = "yes"; then
+ AC_MSG_ERROR([libsystemd-login support requested but libsystemd-login library not found])
fi
fi
fi
-AC_SUBST(SYSTEMD_CFLAGS)
-AC_SUBST(SYSTEMD_LIBS)
-AM_CONDITIONAL(HAVE_SYSTEMD, [test "$have_systemd" = "yes"], [Using systemd])
+AC_SUBST(LIBSYSTEMD_LOGIN_CFLAGS)
+AC_SUBST(LIBSYSTEMD_LOGIN_LIBS)
+AM_CONDITIONAL(HAVE_LIBSYSTEMD_LOGIN, [test "$have_libsystemd_login" = "yes"], [Using libsystemd-login])
dnl ---------------------------------------------------------------------------
dnl - Select which authentication framework to use