summaryrefslogtreecommitdiff
path: root/src/programs/Makefile.am
diff options
context:
space:
mode:
authorDavid Zeuthen <davidz@redhat.com>2009-11-11 17:08:36 -0500
committerDavid Zeuthen <davidz@redhat.com>2009-11-11 17:08:36 -0500
commit8f7727e1df53e9eaa2a36fd6ee8eaf41b209a3f0 (patch)
tree71de5320a177a1d76549ae1725e068d45e4567be /src/programs/Makefile.am
parent00c00948004b605d424d1e74c91dea5521042571 (diff)
downloadpolkit-8f7727e1df53e9eaa2a36fd6ee8eaf41b209a3f0.tar.gz
Port lockdown from pklalockdown(1) to D-Bus methods
Also rename the action from org.freedesktop.policykit.localauthority.lockdown to org.freedesktop.policykit.lockdown since any authority implementation can now implement this. This changes only ABI/API used by e.g. polkit-gnome. This is fine since we're not at 1.0 yet.
Diffstat (limited to 'src/programs/Makefile.am')
-rw-r--r--src/programs/Makefile.am15
1 files changed, 1 insertions, 14 deletions
diff --git a/src/programs/Makefile.am b/src/programs/Makefile.am
index 1898cdd..6f78c49 100644
--- a/src/programs/Makefile.am
+++ b/src/programs/Makefile.am
@@ -17,7 +17,7 @@ INCLUDES = \
# ----------------------------------------------------------------------------------------------------
-bin_PROGRAMS = pkexec pkcheck pkaction pklalockdown
+bin_PROGRAMS = pkexec pkcheck pkaction
# ----------------------------------------------------------------------------------------------------
@@ -82,19 +82,6 @@ pkaction_LDADD = \
# ----------------------------------------------------------------------------------------------------
-pklalockdown_SOURCES = pklalockdown.c
-
-pklalockdown_CFLAGS = \
- $(GLIB_CFLAGS) \
- $(NULL)
-
-pklalockdown_LDADD = \
- $(GLIB_LIBS) \
- $(top_builddir)/src/polkit/libpolkit-gobject-1.la \
- $(NULL)
-
-# ----------------------------------------------------------------------------------------------------
-
clean-local :
rm -f *~