summaryrefslogtreecommitdiff
path: root/src/polkitagent/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/polkitagent/Makefile.am')
-rw-r--r--src/polkitagent/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/polkitagent/Makefile.am b/src/polkitagent/Makefile.am
index c8420fa..3bc364e 100644
--- a/src/polkitagent/Makefile.am
+++ b/src/polkitagent/Makefile.am
@@ -94,6 +94,7 @@ endif
polkit_agent_helper_1_CFLAGS = \
-D_POLKIT_COMPILATION \
+ $(SUID_CFLAGS) \
$(GLIB_CFLAGS) \
$(NULL)
@@ -103,6 +104,11 @@ polkit_agent_helper_1_LDADD = \
$(top_builddir)/src/polkit/libpolkit-gobject-1.la \
$(NULL)
+polkit_agent_helper_1_LDFLAGS = \
+ $(SUID_LDFLAGS) \
+ $(AM_LDFLAGS) \
+ $(NULL)
+
if HAVE_INTROSPECTION
girdir = $(INTROSPECTION_GIRDIR)