summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2009-06-23 11:07:37 +0100
committerMichael Biebl <biebl@debian.org>2009-06-23 11:07:37 +0100
commit62b1f9d1c05362d94d91048f2332339c5767381b (patch)
tree59315ee8688a2284e6bba5a7826ff304b6511a53 /Makefile.am
parentab9c4e360b143e9b9f78ae80c9da62ecc131e672 (diff)
downloadrsyslog-62b1f9d1c05362d94d91048f2332339c5767381b.tar.gz
Imported Upstream version 4.2.0upstream/4.2.0
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d783a30..97f4aed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -88,6 +88,14 @@ if ENABLE_IMTEMPLATE
SUBDIRS += plugins/imtemplate
endif
+if ENABLE_OMSTDOUT
+SUBDIRS += plugins/omstdout
+endif
+
+if ENABLE_OMTEMPLATE
+SUBDIRS += plugins/omtemplate
+endif
+
if ENABLE_IMFILE
SUBDIRS += plugins/imfile
endif
@@ -108,4 +116,11 @@ endif
# modules that need to be generated first
SUBDIRS += tests
+# make sure "make distcheck" tries to build all modules. This means that
+# a developer must always have an environment where every supporting library
+# is available. If that is not the case, the respective configure option may
+# temporarily be removed below. The intent behind forcing everthing to compile
+# in a make distcheck is so that we detect code that accidently was not updated
+# when some global update happened.
+DISTCHECK_CONFIGURE_FLAGS=--enable-gssapi_krb5 --enable-imfile --enable-snmp --enable-pgsql --enable-libdbi --enable-mysql --enable-omtemplate --enable-imtemplate --enable-relp --enable-rsyslogd --enable-mail --enable-klog --enable-diagtools --enable-gnutls --enable-omstdout
ACLOCAL_AMFLAGS = -I m4