summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2013-05-06 23:42:52 +0200
committerMichael Biebl <biebl@debian.org>2013-05-06 23:42:52 +0200
commitd5e3be17e7d29f5464bf8ed0130e92928ad099e8 (patch)
tree3c8923b52b1eff433b72d97ebb432c4ed9b840bd /configure.ac
parent4b0c6b727da98c61470fa2de20396ba6f284c417 (diff)
downloadrsyslog-d5e3be17e7d29f5464bf8ed0130e92928ad099e8.tar.gz
Imported Upstream version 7.3.14upstream/7.3.14
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 26 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 87b65e8..e18a0a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.61)
-AC_INIT([rsyslog],[7.3.12],[rsyslog@lists.adiscon.com])
+AC_INIT([rsyslog],[7.3.14],[rsyslog@lists.adiscon.com])
AM_INIT_AUTOMAKE
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
@@ -798,12 +798,14 @@ if test "x$enable_libgcrypt" = "xyes"; then
[LIBGCRYPT_CFLAGS="`libgcrypt-config --cflags`"
LIBGCRYPT_LIBS="`libgcrypt-config --libs`"
],
- [AC_MSG_FAILURE([libgrypt is missing])],
+ [AC_MSG_FAILURE([libgcrypt is missing])],
[`libgcrypt-config --libs --cflags`]
)
AC_DEFINE([ENABLE_LIBGCRYPT], [1], [Indicator that LIBGCRYPT is present])
fi
AM_CONDITIONAL(ENABLE_LIBGCRYPT, test x$enable_libgcrypt = xyes)
+AC_SUBST(LIBGCRYPT_CFLAGS)
+AC_SUBST(LIBGCRYPT_LIBS)
# support for building the rsyslogd runtime
@@ -1367,6 +1369,26 @@ AM_CONDITIONAL(ENABLE_OMZMQ3, test x$enable_omzmq3 = xyes)
# END ZMQ3 SUPPORT
+# BEGIN RABBITMQ OUTPUT SUPPORT
+
+AC_ARG_ENABLE(omrabbitmq,
+ [AS_HELP_STRING([--enable-omrabbitmq],[Compiles omrabbitmq output module @<:@default=no@:>@])],
+ [case "${enableval}" in
+ yes) enable_omrabbitmq="yes" ;;
+ no) enable_omrabbitmq="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-omrabbitmq) ;;
+ esac],
+ [enable_omrabbitmq=no]
+)
+if test "x$enable_omrabbitmq" = "xyes"; then
+ PKG_CHECK_MODULES(RABBITMQ, librabbitmq >= 0.2.0)
+ AC_SUBST(RABBITMQ_CFLAGS)
+ AC_SUBST(RABBITMQ_LIBS)
+fi
+AM_CONDITIONAL(ENABLE_OMRABBITMQ, test x$enable_omrabbitmq = xyes)
+
+# END RABBITMQ SUPPORT
+
# HIREDIS SUPPORT
AC_ARG_ENABLE(omhiredis,
@@ -1433,6 +1455,7 @@ AC_CONFIG_FILES([Makefile \
plugins/ommongodb/Makefile \
plugins/omhiredis/Makefile \
plugins/omzmq3/Makefile \
+ plugins/omrabbitmq/Makefile \
plugins/mmnormalize/Makefile \
plugins/mmjsonparse/Makefile \
plugins/mmaudit/Makefile \
@@ -1483,6 +1506,7 @@ echo " omruleset module will be compiled: $enable_omruleset"
echo " omudpspoof module will be compiled: $enable_omudpspoof"
echo " omuxsock module will be compiled: $enable_omuxsock"
echo " omzmq3 module will be compiled: $enable_omzmq3"
+echo " omrabbitmq module will be compiled: $enable_omrabbitmq"
echo
echo "---{ parser modules }---"
echo " pmrfc3164sd module will be compiled: $enable_pmrfc3164sd"