summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2013-06-26 21:00:34 +0200
committerMichael Biebl <biebl@debian.org>2013-06-26 21:13:27 +0200
commit8d984c2d63a196e9f836fd2f619c2a59298d1241 (patch)
tree974b151918a83cce6171fe932b2ede41748b3169 /debian
parent822c2927e2dc714b48e9092ada1b89889f33fd74 (diff)
downloadrsyslog-8d984c2d63a196e9f836fd2f619c2a59298d1241.tar.gz
Use dh-systemd for proper systemd support
Instead of shipping the symlinks from "systemctl enable rsyslog.service" in the package we rely on dh-systemd to setup the service properly.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/control1
-rw-r--r--debian/rsyslog.links2
-rw-r--r--debian/rsyslog.prerm10
-rwxr-xr-xdebian/rules2
5 files changed, 18 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 7b2a9af..328c3ea 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+rsyslog (7.4.1-2) UNRELEASED; urgency=low
+
+ * Use dh-systemd to setup the systemd service properly.
+
+ -- Michael Biebl <biebl@debian.org> Thu, 20 Jun 2013 06:15:06 +0200
+
rsyslog (7.4.1-1) unstable; urgency=low
* New upstream release.
diff --git a/debian/control b/debian/control
index b4bfe1d..f8e3720 100644
--- a/debian/control
+++ b/debian/control
@@ -5,6 +5,7 @@ Maintainer: Michael Biebl <biebl@debian.org>
Build-Depends: debhelper (>= 8),
dpkg-dev (>= 1.16.1),
dh-autoreconf,
+ dh-systemd (>= 1.3),
zlib1g-dev,
libmysqlclient-dev,
libpq-dev,
diff --git a/debian/rsyslog.links b/debian/rsyslog.links
deleted file mode 100644
index c9d3179..0000000
--- a/debian/rsyslog.links
+++ /dev/null
@@ -1,2 +0,0 @@
-lib/systemd/system/rsyslog.service etc/systemd/system/multi-user.target.wants/rsyslog.service
-lib/systemd/system/rsyslog.service etc/systemd/system/syslog.service
diff --git a/debian/rsyslog.prerm b/debian/rsyslog.prerm
new file mode 100644
index 0000000..503b849
--- /dev/null
+++ b/debian/rsyslog.prerm
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+set -e
+
+# Stop the socket on remove so rsyslog is not restarted via socket activation
+if [ -d /run/systemd/system ] && [ "$1" = remove ] ; then
+ systemctl stop syslog.socket || true
+fi
+
+#DEBHELPER#
diff --git a/debian/rules b/debian/rules
index 2616c8c..0d6b48b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,7 +6,7 @@ include /usr/share/dpkg/buildflags.mk
DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
%:
- dh $@ --with autoreconf
+ dh $@ --with autoreconf,systemd
ifeq ($(DEB_HOST_ARCH_OS), linux)
confflags += --enable-imptcp \