summaryrefslogtreecommitdiff
path: root/debian/patches/48screen-ipv6.patch
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2014-05-11 15:48:13 +0400
committerIgor Pashev <pashev.igor@gmail.com>2014-05-11 15:48:13 +0400
commit25399d502ec5733044f4975e819994ee231e982f (patch)
tree2e1a26e5082912c2c627acdd2e865bbcb19050e1 /debian/patches/48screen-ipv6.patch
parent13a4d5f1001b28e1bf5db42d67c99d158fc28cc7 (diff)
parent3fa7de8dc211d403899ed68b0f5b4ec0b62301a1 (diff)
downloadscreen-25399d502ec5733044f4975e819994ee231e982f.tar.gz
Merge branch 'master' of git://anonscm.debian.org/collab-maint/screen
Conflicts: debian/changelog debian/control debian/rules
Diffstat (limited to 'debian/patches/48screen-ipv6.patch')
-rw-r--r--debian/patches/48screen-ipv6.patch46
1 files changed, 23 insertions, 23 deletions
diff --git a/debian/patches/48screen-ipv6.patch b/debian/patches/48screen-ipv6.patch
index 36526cc..f632d93 100644
--- a/debian/patches/48screen-ipv6.patch
+++ b/debian/patches/48screen-ipv6.patch
@@ -2,12 +2,12 @@ Author: <bpkroth@gmail.com>
Description: Some patches stolen from the fedora package for better error checking and tty security.
Index: screen/doc/screen.1
===================================================================
---- screen.orig/doc/screen.1 2012-03-20 22:41:10.000000000 +0100
-+++ screen/doc/screen.1 2012-03-20 22:41:13.000000000 +0100
-@@ -398,6 +398,12 @@
- the \fB-d\fP or \fB-r\fP option to tell screen to look only for
- attached or detached screen sessions. Note that this command doesn't
- work if the session is password protected.
+--- screen.orig/doc/screen.1 2014-04-17 14:23:06.359089910 +0200
++++ screen/doc/screen.1 2014-04-17 14:23:06.343089985 +0200
+@@ -400,6 +400,12 @@
+ \fB-r\fP option to tell screen to look only for attached or
+ detached screen sessions. Note that this command doesn't work if
+ the session is password protected.
+.TP 5
+.B \-4
+Resolve hostnames only to IPv4 addresses.
@@ -19,8 +19,8 @@ Index: screen/doc/screen.1
.ta 12n 26n
Index: screen/extern.h
===================================================================
---- screen.orig/extern.h 2012-03-20 22:41:12.000000000 +0100
-+++ screen/extern.h 2012-03-20 22:41:13.000000000 +0100
+--- screen.orig/extern.h 2014-04-17 14:23:06.359089910 +0200
++++ screen/extern.h 2014-04-17 14:23:06.343089985 +0200
@@ -459,8 +459,7 @@
/* teln.c */
@@ -33,8 +33,8 @@ Index: screen/extern.h
extern int DoTelnet __P((char *, int *, int));
Index: screen/help.c
===================================================================
---- screen.orig/help.c 2012-03-20 22:14:48.000000000 +0100
-+++ screen/help.c 2012-03-20 22:41:13.000000000 +0100
+--- screen.orig/help.c 2014-04-17 14:23:06.359089910 +0200
++++ screen/help.c 2014-04-17 14:23:06.347089970 +0200
@@ -66,6 +66,10 @@
{
printf("Use: %s [-opts] [cmd [args]]\n", myname);
@@ -48,8 +48,8 @@ Index: screen/help.c
printf("-c file Read configuration file instead of '.screenrc'.\n");
Index: screen/screen.c
===================================================================
---- screen.orig/screen.c 2012-03-20 22:41:12.000000000 +0100
-+++ screen/screen.c 2012-03-20 22:41:13.000000000 +0100
+--- screen.orig/screen.c 2014-04-17 14:23:06.359089910 +0200
++++ screen/screen.c 2014-04-17 14:23:06.347089970 +0200
@@ -248,8 +248,9 @@
struct win *fore;
struct win *windows;
@@ -89,8 +89,8 @@ Index: screen/screen.c
break;
Index: screen/teln.c
===================================================================
---- screen.orig/teln.c 2012-03-20 22:14:48.000000000 +0100
-+++ screen/teln.c 2012-03-20 22:41:13.000000000 +0100
+--- screen.orig/teln.c 2014-04-17 14:23:06.359089910 +0200
++++ screen/teln.c 2014-04-17 14:23:06.347089970 +0200
@@ -30,6 +30,7 @@
#include <sys/socket.h>
#include <fcntl.h>
@@ -271,9 +271,9 @@ Index: screen/teln.c
int
Index: screen/window.c
===================================================================
---- screen.orig/window.c 2012-03-20 22:35:13.000000000 +0100
-+++ screen/window.c 2012-03-20 22:41:13.000000000 +0100
-@@ -607,6 +607,13 @@
+--- screen.orig/window.c 2014-04-17 14:23:06.359089910 +0200
++++ screen/window.c 2014-04-17 14:23:06.351089971 +0200
+@@ -611,6 +611,13 @@
n = pp - wtab;
debug1("Makewin creating %d\n", n);
@@ -287,7 +287,7 @@ Index: screen/window.c
if ((f = OpenDevice(nwin.args, nwin.lflag, &type, &TtyName)) < 0)
return -1;
if (type == W_TYPE_GROUP)
-@@ -768,7 +775,7 @@
+@@ -772,7 +779,7 @@
#ifdef BUILTIN_TELNET
if (type == W_TYPE_TELNET)
{
@@ -296,7 +296,7 @@ Index: screen/window.c
{
FreeWindow(p);
return -1;
-@@ -880,6 +887,13 @@
+@@ -884,6 +891,13 @@
int lflag, f;
lflag = nwin_default.lflag;
@@ -310,7 +310,7 @@ Index: screen/window.c
if ((f = OpenDevice(p->w_cmdargs, lflag, &p->w_type, &TtyName)) < 0)
return -1;
-@@ -913,7 +927,7 @@
+@@ -917,7 +931,7 @@
#ifdef BUILTIN_TELNET
if (p->w_type == W_TYPE_TELNET)
{
@@ -319,7 +319,7 @@ Index: screen/window.c
return -1;
}
else
-@@ -1072,16 +1086,6 @@
+@@ -1076,16 +1090,6 @@
*namep = "telnet";
return 0;
}
@@ -338,8 +338,8 @@ Index: screen/window.c
Msg(0, "Invalid argument '%s'", arg);
Index: screen/window.h
===================================================================
---- screen.orig/window.h 2012-03-20 22:14:48.000000000 +0100
-+++ screen/window.h 2012-03-20 22:41:13.000000000 +0100
+--- screen.orig/window.h 2014-04-17 14:23:06.359089910 +0200
++++ screen/window.h 2014-04-17 14:23:06.351089971 +0200
@@ -268,7 +268,7 @@
struct display *w_zdisplay;
#endif