summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJuan Cespedes <cespedes@debian.org>1998-02-22 11:16:46 +0100
committerAxel Beckert <abe@deuxchevaux.org>2011-09-03 14:05:22 +0200
commitb84c852136060bca15274e7e8f66aa1e84a6c566 (patch)
tree85544acb697b5838f0343a9da973e178ba2f0c4c /debian/rules
parent46e81bca4286a25df6c3ec39234c7e2392af4ef0 (diff)
parent14a4b00c9ef680b78469333291270e4c276f100d (diff)
downloadscreen-b84c852136060bca15274e7e8f66aa1e84a6c566.tar.gz
Imported Debian patch 3.7.4-6debian/3.7.4-6
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules148
1 files changed, 42 insertions, 106 deletions
diff --git a/debian/rules b/debian/rules
index 7453449..32235dd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,115 +1,51 @@
#!/usr/bin/make -f
-# -*- mode: makefile; -*-
#
-# Last updated: Sat Dec 17 10:52:20 EST 1994 by imurdock.
-#
-# To make the binary distribution package, the ``Debianized'' source package
-# and the context diff to the original package, type `./debian.rules dist'.
-# Make sure that `debian.rules' is executable before the final distribution
-# is made.
-#
-# Invoke each target with `./debian.rules <target>'. All targets should be
-# invoked with the package root as the current directory.
-#
-# The `binary' target must be run as root, as it needs to install files with
-# specific ownerships. The `diff' target assumes that you have the original
-# source package available, unpacked, in ../$(p)-$(v).orig, or that you have
-# the previous revision of the ``Debianized'' source package and context diff
-# in the parent directory.
-
-CC = gcc
-CFLAGS = -O2
-LDFLAGS = -s
-
-# The name of the package (for example, `emacs').
-p = screen
-# # The version of the package (for example, `19.28').
-v = 3.7.2
-# # The Debian revision of the package (for example, `2').
-# d = 8
-# # The target architecture.
-# a = $(shell dpkg --print-architecture)
-# package=$(p)
-# version=$(v)
-# debian=$(d)
-# arch=$(a)
+# Copyright (C) 1997 joost witteveen <joost@rulcmc.leidenuniv.nl>
+# Copyright (C) 1997 Juan Cespedes <cespedes@debian.org>
build:
-# Builds the binary package.
- ./configure --prefix=/usr
- make CC="$(CC)" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
- touch build
-
-clean:
-# Undoes the effect of `debian/rules build'.
- -$(MAKE) distclean
- rm -f comm.h config.h kmapdef.c term.h tty.c
- rm -f build
- rm -rf debian/tmp
- rm -f Makefile.rej*
-
-binary-indep: checkroot build
- $(checkdir)
-# There are no architecture-independent files to be uploaded
-# generated by this package. If there were any they would be
-# made here.
-
-binary-arch: checkroot build
-# Makes a binary package.
- rm -rf debian/tmp
- install -d -g root -m 755 -o root debian/tmp
- chmod g-s debian/tmp
- install -d -g root -m 755 -o root debian/tmp/DEBIAN
- install -d -g root -m 755 -o root debian/tmp/etc
- install -d -g root -m 755 -o root debian/tmp/usr/bin
- install -d -g root -m 755 -o root debian/tmp/usr/info
- install -d -g root -m 755 -o root debian/tmp/usr/man/man1
- install -d -g root -m 755 -o root debian/tmp/usr/doc/$(p)
- install -g root -m 644 -o root etc/etcscreenrc \
- debian/tmp/etc/screenrc
- install -g root -m 4755 -o root screen \
- debian/tmp/usr/bin/screen-$(v)
- ( cd debian/tmp/usr/bin ; ln -fs screen-$(v) screen )
- install -g root -m 644 -o root doc/screen.info* \
- debian/tmp/usr/info
- install -g root -m 644 -o root doc/screen.1 \
- debian/tmp/usr/man/man1/screen.1
- install -g root -m 644 -o root terminfo/* \
- debian/tmp/usr/doc/screen
- install -g root -m 644 -o root debian/copyright \
- debian/tmp/usr/doc/$(p)/copyright
- install -g root -m 644 -o root debian/changelog \
- debian/tmp/usr/doc/$(p)/changelog.Debian
- rm -f debian/tmp/usr/info/$(p).info*.gz
- gzip -9f debian/tmp/usr/info/$(p).info* \
- debian/tmp/usr/doc/$(p)/*
- gunzip debian/tmp/usr/doc/$(p)//screeninfo.src
- install -g root -m 755 -o root debian/conffiles \
- debian/tmp/DEBIAN/conffiles
- install -g root -m 755 -o root debian/postinst \
- debian/tmp/DEBIAN/postinst
- install -g root -m 755 -o root debian/postrm \
- debian/tmp/DEBIAN/postrm
- dpkg-shlibdeps screen
- dpkg-gencontrol
- chown -R root.root debian/tmp
- chmod -R g-ws debian/tmp
- dpkg --build debian/tmp ..
-
-
-define checkdir
- test -f $(p).c -a -f debian/rules
-endef
-
-# Below here is fairly generic really
+ ./configure --prefix=/usr
+ $(MAKE) CFLAGS='-O2 -g -Wall'
+ touch build
binary: binary-indep binary-arch
-source diff:
- @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
+binary-indep:
+
+binary-arch: build
+ @test 0 = `id -u` || { echo "Error: not super-user"; exit 1; }
+ rm -rf debian/tmp
+ install -d -m 755 debian/tmp/{DEBIAN,etc,usr/{bin,info,man/man1,doc/screen}}
+ cp -a etc/etcscreenrc debian/tmp/etc/screenrc
+ install -s -m 4755 screen debian/tmp/usr/bin/screen
+ cp -a doc/screen.info* debian/tmp/usr/info
+ cp -a doc/screen.1 debian/tmp/usr/man/man1/screen.1
+ cp -a debian/changelog debian/tmp/usr/doc/screen/changelog.Debian
+ cp -a ChangeLog debian/tmp/usr/doc/screen/changelog
+ cp -a README NEWS FAQ debian/tmp/usr/doc/screen
+ rm -f debian/tmp/usr/info/screen.info*.gz
+ gzip -9f debian/tmp/usr/info/screen.info* debian/tmp/usr/doc/screen/*
+ gzip -9f debian/tmp/usr/man/man1/*
+ install -d debian/tmp/usr/doc/screen/terminfo
+ cp -a terminfo/* debian/tmp/usr/doc/screen/terminfo
+ cp -a debian/README.terminfo debian/tmp/usr/doc/screen/terminfo/README.Debian
+ gzip -9f debian/tmp/usr/doc/screen/terminfo/*
+ cp -a debian/copyright debian/tmp/usr/doc/screen/copyright
+ cp -a debian/conffiles debian/tmp/DEBIAN/conffiles
+ install -m 755 debian/postinst debian/tmp/DEBIAN/postinst
+ install -m 755 debian/postrm debian/tmp/DEBIAN/postrm
+
+ dpkg-shlibdeps screen
+ dpkg-gencontrol
+ chown -R root.root debian/tmp
+ chmod -R go=rX debian/tmp
+ dpkg --build debian/tmp ..
-checkroot:
- $(checkdir)
- test root = "`whoami`"
+clean:
+ rm -f build debian/files debian/substvars
+ -$(MAKE) realclean
+ rm -f kmapdef.c
+ rm -f osdef[012]*
+ rm -rf debian/tmp
-.PHONY: binary binary-arch binary-indep clean checkroot
+.PHONY: binary binary-arch binary-indep clean