summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/install2
-rwxr-xr-xdebian/rules4
3 files changed, 4 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 9e73273..19eb535 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -13,6 +13,7 @@ screen (4.1.0~20120320gitdb59704-8) UNRELEASED; urgency=low
+ Drop manual DEB_BUILD_OPTIONS parsing
+ Use debian/clean instead of dh_clean parameters and add some more
files to clean up
+ + Use dh_install and debian/install instead of install and cp
* Apply wrap-and-sort.
-- Axel Beckert <abe@debian.org> Thu, 16 May 2013 03:15:42 +0200
diff --git a/debian/install b/debian/install
new file mode 100644
index 0000000..34e5e10
--- /dev/null
+++ b/debian/install
@@ -0,0 +1,2 @@
+debian/screenrc etc/
+debian/README.terminfo usr/share/doc/screen/terminfo/
diff --git a/debian/rules b/debian/rules
index 8939827..2c3462d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -57,8 +57,6 @@ install-stamp: build-stamp
# can't call the normal install target b/c it installs the info files
# and other crud
$(MAKE) prefix=$(ROOT)/usr SCREENENCODINGS='$$(prefix)/share/screen/utf8encodings' installdirs install_bin
- # install the debian screenrc to etc
- install -m 644 debian/screenrc $(ROOT)/etc
# hack around the fact that the install target makes screen a symlink to screen-$$(VERSION)
rm -f $(ROOT)/usr/bin/screen
mv -f $(ROOT)/usr/bin/screen* $(ROOT)/usr/bin/screen
@@ -73,7 +71,7 @@ binary-arch: install
dh_testdir
dh_testroot
dh_installdocs
- cp debian/README.terminfo $(ROOT)/usr/share/doc/screen/terminfo/
+ dh_install
dh_installexamples
dh_installman || true
dh_installinfo