summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAndreas Beckmann <anbe@debian.org>2013-10-21 23:15:23 +0200
committerAndreas Beckmann <anbe@debian.org>2013-10-21 23:15:23 +0200
commit4d8da83a49efb2c7f101e2c36ea9c5d4c72c71d2 (patch)
tree1138354b3ad5d23f9e8b9efc147517744d57e30c /debian
parent47e88ca1f0dcdfda6024ec292948181163e2d0e3 (diff)
downloadsendmail-4d8da83a49efb2c7f101e2c36ea9c5d4c72c71d2.tar.gz
support passing automake arguments for the refresh-debian-configure target
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 8ae2056..2388432 100755
--- a/debian/rules
+++ b/debian/rules
@@ -187,6 +187,8 @@ refresh-debian::
# Maintainer only rule... refresh debian/configure and debian/*/Makefile.in
AUTOFOODUMMY = debian/AUTHORS debian/COPYING debian/ChangeLog debian/INSTALL debian/NEWS debian/README
AUTOFOODUMMY += debian/build/debian/changelog.in
+AUTOMAKEARGS ?= --force
+AUTOMAKEARGS ?= --force --force-missing --add-missing --copy
refresh-debian-configure:
touch $(AUTOFOODUMMY)
# unpack
@@ -194,7 +196,7 @@ refresh-debian-configure:
# regenerate
cd debian && aclocal -I ./build
cd debian && autoconf
- -cd debian && automake
+ cd debian && automake $(AUTOMAKEARGS)
# regenerate more
$(RM) debian/stamp-autotools
debian/rules configure