summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules9
1 files changed, 4 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 99b92ca..89c4cb4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -158,7 +158,6 @@ refresh-debian-configure:
.PHONY: clean-debian
clean-debian::
@echo 'cleaning debian directory...';
- #-(cd debian && $(MAKE) -f Makefile maintainer-clean;)
#-(cd debian && $(MAKE) -f Makefile distclean;)
find debian -name '*~' -o -name '\.*\.swp' \
| xargs -r $(RM);
@@ -248,7 +247,7 @@ clean::
#
# Local stuff
-if [ -f debian/Makefile ]; then \
- (cd debian && $(MAKE) -f Makefile clean maintainer-clean;) \
+ $(MAKE) -C debian -f Makefile clean maintainer-clean; \
fi;
# Debian stuff
$(RM) -r ${_cdbs_tarball_dir};
@@ -271,9 +270,9 @@ common-build-indep::
# build-indep:
#
# sendmail operations guide
- (cd ${DEB_SRCDIR}/doc/op/ && GROFF_NO_SGR=1 make op.txt);
+ GROFF_NO_SGR=1 $(MAKE) -C ${DEB_SRCDIR}/doc/op/ op.txt
# Debian stuff
- (cd debian && $(MAKE) -f Makefile build-indep;)
+ $(MAKE) -C debian -f Makefile build-indep
#--------------------------------------------------------------------
@@ -328,7 +327,7 @@ common-build-arch::
fi; \
done;
# Debian stuff
- (cd debian && $(MAKE) -f Makefile build-arch;)
+ $(MAKE) -C debian -f Makefile build-arch
# Remove our config m4 files
$(RM) ${DEB_SRCDIR}/devtools/Site/site.config.m4;
#--------------------------------------------------------------------