summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2017-06-21 15:00:21 +0300
committerIgor Pashev <pashev.igor@gmail.com>2017-06-21 15:00:21 +0300
commit6896b3c90de4725b0ddc8e62516b9f4afc32f8bf (patch)
treee41b909f74d3ed35e7cc2423da69c34a05d4cdd6 /debian/rules
parent3b1a81504cb67ec6b1477e1e409fdac86c9c3371 (diff)
downloadsudo-6896b3c90de4725b0ddc8e62516b9f4afc32f8bf.tar.gz
Add SMF service
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 9 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 3f29600..30c9206 100755
--- a/debian/rules
+++ b/debian/rules
@@ -148,6 +148,15 @@ ifeq ($(DEB_HOST_ARCH_OS),linux)
debian/sudo-ldap/lib/systemd/system/sudo.service
endif
+ifeq ($(DEB_HOST_ARCH_OS),illumos)
+ # we don't need postinst scripts (and dh-smf), as this service is for boot time only
+ set -x; for p in sudo sudo-ldap; do \
+ mkdir -p debian/$$p/lib/svc/manifest/system && \
+ install -o root -g root -m 0644 debian/sudo-smf.xml \
+ debian/$$p/lib/svc/manifest/system/sudo.xml ; \
+ done
+endif
+
binary-indep: build install
binary-arch: build install