summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStepan Kasal <skasal@redhat.com>2007-05-15 20:46:12 +0200
committerKarel Zak <kzak@redhat.com>2007-05-16 11:43:29 +0200
commitd7b745465456dcecd8056d26fc7139bb26c8e03c (patch)
treee38855757af486d9b2e1010892d1b9fc620314a5 /Makefile.am
parentcaec351d6709852bf80bacec6fac6a55302357fe (diff)
downloadutil-linux-old-d7b745465456dcecd8056d26fc7139bb26c8e03c.tar.gz
build-sys: use dist_noinst_DATA to work around the bug with dist_man_MANS
Automake mishandles dist_man_MANS. Using dist_noinst_DATA to work around this is more elegant than using dist-hook. Signed-off-by: Stepan Kasal <skasal@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 0 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index feb98d95..1d964acb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,12 +39,3 @@ mrproper: distclean
cd config; rm -f `cat ../.gitignore`; cd .. ; \
cd po; rm -f `cat .gitignore`; cd .. ; \
fi
-
-# The automake is very stupid for work with man pages. The files from man_MANS are
-# not included to the distribution. A solution is use dist_man_MANS or
-# EXTRA_DIST = $(man_MANS) -- but these solutions are ugly in case that there
-# is a lot of "if <cond>", because the result in EXTRA_DIST or dist_man_MANS
-# depends on the condition ;-(
-dist-hook:
- -find -regex "\./[a-z\-]*/[a-z\.\-\_]*\.[1-9]" -exec cp {} $(distdir)/{} \;
-