summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak <kzak@redhat.com>2009-05-21 15:52:24 +0200
committerKarel Zak <kzak@redhat.com>2009-05-22 10:06:16 +0200
commit3ac22f7a17cb1040e3ca962a805ded3ef812dd28 (patch)
tree28c703190a3e2385bc03b4f0c417bd6780e2ecaf /configure.ac
parent6c2a09b3e65b9fad67087577a9c86377f3f3b98b (diff)
downloadutil-linux-old-3ac22f7a17cb1040e3ca962a805ded3ef812dd28.tar.gz
build-sys: add --disable-tls
* add AX_TLS autoconf macro * add --disabletls option * cleanup gen_uuid.c code to remove gcc warnings when compiled without TLS macro. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 92f40d49..0b3cf359 100644
--- a/configure.ac
+++ b/configure.ac
@@ -128,6 +128,7 @@ AC_CHECK_FUNCS(
nanosleep \
personality \
updwtmp \
+ jrand48 \
lchown \
llseek \
lseek64 \
@@ -211,6 +212,15 @@ AC_DEFUN([UTIL_RESTORE_FLAGS], [
])
+AC_ARG_ENABLE([tls],
+ AS_HELP_STRING([--disable-tls], [disable use of thread local support]),
+ [], enable_tls=yes
+)
+if test "x$enable_tls" = xyes; then
+ AX_TLS
+fi
+
+
AC_ARG_ENABLE([mount],
AS_HELP_STRING([--disable-mount], [do not build mount utilities]),
[], enable_mount=check