summaryrefslogtreecommitdiff
path: root/fdisk/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak <kzak@redhat.com>2007-07-02 13:21:06 +0200
committerKarel Zak <kzak@redhat.com>2007-07-02 13:21:06 +0200
commite782f1d4000686207152dd31a12d67457a684ea5 (patch)
tree21fb78704aa06c4dde40cca7ecacc61b70dea4de /fdisk/Makefile.am
parent2dfd8e6276ca23ad1d8e7e7d14dcbcf7ed3b1c48 (diff)
downloadutil-linux-old-e782f1d4000686207152dd31a12d67457a684ea5.tar.gz
build-sys: cleanup architecture conditionals
This patch also add some new architectures for AM_CONDITIONAL(ARCH_ ...) Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'fdisk/Makefile.am')
-rw-r--r--fdisk/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/fdisk/Makefile.am b/fdisk/Makefile.am
index 9561fef2..c149263b 100644
--- a/fdisk/Makefile.am
+++ b/fdisk/Makefile.am
@@ -4,7 +4,7 @@ EXTRA_DIST = README.fdisk README.cfdisk sfdisk.examples partitiontype.c
fdisk_common = disksize.c i386_sys_types.c common.h gpt.c gpt.h
-if !M68K
+if !ARCH_M68K
sbin_PROGRAMS = fdisk
man_MANS = fdisk.8
@@ -13,7 +13,7 @@ fdisk_SOURCES = fdisk.c fdiskbsdlabel.c fdisksgilabel.c \
fdisk.h fdisksunlabel.h fdisksgilabel.h fdiskaixlabel.h \
fdiskbsdlabel.h fdiskmaclabel.h $(fdisk_common)
-if !SPARC
+if !ARCH_SPARC
sbin_PROGRAMS += sfdisk
man_MANS += sfdisk.8
@@ -33,6 +33,6 @@ cfdisk_LDADD = -lncurses
endif
endif
-endif # !SPARC
-endif # !M68K
+endif # !ARCH_SPARC
+endif # !ARCH_M68K