summaryrefslogtreecommitdiff
path: root/hwclock/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak <kzak@redhat.com>2007-03-21 14:12:05 +0100
committerKarel Zak <kzak@redhat.com>2007-03-21 14:12:05 +0100
commit88058a71e27a5b4ded2879b774aaf1c1a15944ca (patch)
tree70494baa53324375eda8c44ebbfd46ad00e358da /hwclock/Makefile.am
parent99c392d8ba163e35b9d562dd4bcf7dd476ad3573 (diff)
downloadutil-linux-old-88058a71e27a5b4ded2879b774aaf1c1a15944ca.tar.gz
hwclock: add support for audit system
If you compile --with-audit the hwclock tool reports changes in sys/hw clock to audit system. The real long-term and final solution is probably add hooks for /dev/rtc to kernel, but it's not implemented yet. Signed-off-by: Steve Grubb <sgrubb@redhat.com> Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'hwclock/Makefile.am')
-rw-r--r--hwclock/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/hwclock/Makefile.am b/hwclock/Makefile.am
index d2de9822..80207d0d 100644
--- a/hwclock/Makefile.am
+++ b/hwclock/Makefile.am
@@ -5,5 +5,10 @@ man_MANS = hwclock.8
sbin_PROGRAMS = hwclock
hwclock_SOURCES = hwclock.c cmos.c rtc.c kd.c clock.h
+hwclock_LDADD =
+
+if HAVE_AUDIT
+hwclock_LDADD += -laudit
+endif
EXTRA_DIST = README.* clock-ppc.c