summaryrefslogtreecommitdiff
path: root/mount/Makefile.am
diff options
context:
space:
mode:
authorLaMont Jones <lamont@debian.org>2008-02-21 07:19:30 -0700
committerLaMont Jones <lamont@debian.org>2008-02-21 07:19:30 -0700
commit02c7bd26732561d018a1684a2053556a1206411c (patch)
treebcab8b68b7b4d73d11f1d6e20b7a145b02ebcd97 /mount/Makefile.am
parent52e070ef9ab9927d2331c5bad30395113b2afcc0 (diff)
parent024e1a4f90ad98495863e57132edbadc80a3cac5 (diff)
downloadutil-linux-old-02c7bd26732561d018a1684a2053556a1206411c.tar.gz
Merge commit 'origin/master'
Conflicts: mount/lomount.c mount/losetup.8 mount/mount.c
Diffstat (limited to 'mount/Makefile.am')
-rw-r--r--mount/Makefile.am31
1 files changed, 28 insertions, 3 deletions
diff --git a/mount/Makefile.am b/mount/Makefile.am
index db6f674a..3592eb2a 100644
--- a/mount/Makefile.am
+++ b/mount/Makefile.am
@@ -35,20 +35,45 @@ umount_LDADD = $(LDADD_common)
swapon_LDADD = $(LDADD_common)
LDADD_common =
+LDADD_common_static =
+
+if HAVE_STATIC_MOUNT
+bin_PROGRAMS += mount.static
+mount_static_SOURCES = $(mount_SOURCES)
+mount_static_LDFLAGS = $(LDFLAGS_STATIC)
+mount_static_LDADD = $(LDADD_common_static)
+endif
+
+if HAVE_STATIC_UMOUNT
+bin_PROGRAMS += umount.static
+umount_static_SOURCES = $(umount_SOURCES)
+umount_static_LDFLAGS = $(LDFLAGS_STATIC)
+umount_static_LDADD = $(LDADD_common_static)
+endif
+
+if HAVE_STATIC_LOSETUP
+bin_PROGRAMS += losetup.static
+losetup_static_SOURCES = $(losetup_SOURCES)
+losetup_static_LDFLAGS = $(LDFLAGS_STATIC)
+losetup_static_CPPFLAGS = -DMAIN $(AM_CPPFLAGS)
+endif
if HAVE_BLKID
utils_common += fsprobe_blkid.c
-LDADD_common += -lblkid -luuid
+LDADD_common += $(BLKID_LIBS)
+LDADD_common_static += $(BLKID_LIBS_STATIC)
endif
if HAVE_SELINUX
-mount_LDADD += -lselinux
+mount_LDADD += $(SELINUX_LIBS)
+mount_static_LDADD = $(SELINUX_LIBS_STATIC)
endif
if HAVE_VOLUME_ID
utils_common += fsprobe_volumeid.c
swapon_SOURCES += ../lib/linux_version.c ../lib/blkdev.c
-LDADD_common += -lvolume_id
+LDADD_common += $(VOLUMEID_LIBS)
+LDADD_common_static += $(VOLUMEID_LIBS_STATIC)
endif
if HAVE_PIVOT_ROOT