summaryrefslogtreecommitdiff
path: root/mount/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak <kzak@redhat.com>2007-11-08 00:54:58 +0100
committerKarel Zak <kzak@redhat.com>2007-11-08 00:54:58 +0100
commit461311047bf28ea838ab63e5a5e5b2003af2f377 (patch)
tree5adcb50b7e4f542d65b6fb6bb71d437d77dd66fe /mount/Makefile.am
parent8a4a67b9f16d3f8dd89c7bf88fb3811b7c65f6d2 (diff)
downloadutil-linux-old-461311047bf28ea838ab63e5a5e5b2003af2f377.tar.gz
mount: use blkdev_get_size()
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'mount/Makefile.am')
-rw-r--r--mount/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/mount/Makefile.am b/mount/Makefile.am
index 45674faf..4ba8f56f 100644
--- a/mount/Makefile.am
+++ b/mount/Makefile.am
@@ -8,12 +8,13 @@ man_MANS = fstab.5 mount.8 swapoff.8 swapon.8 umount.8 losetup.8
utils_common = sundries.c xmalloc.c realpath.c fsprobe.c
-headers_common = fstab.h linux_fs.h mount_mntent.h mount_constants.h \
+headers_common = fstab.h mount_mntent.h mount_constants.h \
mount_paths.h lomount.h fsprobe.h realpath.h xmalloc.h \
getusername.h loop.h sundries.h
mount_common = fstab.c mount_mntent.c getusername.c lomount.c \
- $(utils_common) $(headers_common) ../lib/env.c
+ $(utils_common) $(headers_common) ../lib/env.c ../lib/linux_version.c \
+ ../lib/blkdev.c
mount_SOURCES = mount.c $(mount_common) ../lib/setproctitle.c
mount_CFLAGS = $(SUID_CFLAGS) $(AM_CFLAGS)