summaryrefslogtreecommitdiff
path: root/mount/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak <kzak@redhat.com>2008-12-12 14:04:19 +0100
committerKarel Zak <kzak@redhat.com>2008-12-12 14:04:19 +0100
commit4b7473c30f8844de31ce965d465ab2725c54909b (patch)
tree88490e2781329c9ede2a1892a244bbb7f6c90cd8 /mount/Makefile.am
parent9775d40fff67087f277a1aa9c33aa65b26041c4a (diff)
downloadutil-linux-old-4b7473c30f8844de31ce965d465ab2725c54909b.tar.gz
mount: fix mount_static_LDADD
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'mount/Makefile.am')
-rw-r--r--mount/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/mount/Makefile.am b/mount/Makefile.am
index 7ff528ca..3963fdaf 100644
--- a/mount/Makefile.am
+++ b/mount/Makefile.am
@@ -37,12 +37,13 @@ swapon_LDADD = $(LDADD_common)
LDADD_common =
LDADD_common_static =
+mount_static_LDADD =
if HAVE_STATIC_MOUNT
bin_PROGRAMS += mount.static
mount_static_SOURCES = $(mount_SOURCES)
mount_static_LDFLAGS = $(LDFLAGS_STATIC)
-mount_static_LDADD = $(LDADD_common_static)
+mount_static_LDADD += $(LDADD_common_static)
endif
if HAVE_STATIC_UMOUNT
@@ -67,7 +68,7 @@ endif
if HAVE_SELINUX
mount_LDADD += $(SELINUX_LIBS)
-mount_static_LDADD = $(SELINUX_LIBS_STATIC)
+mount_static_LDADD += $(SELINUX_LIBS_STATIC)
endif
if HAVE_VOLUME_ID