summaryrefslogtreecommitdiff
path: root/mount/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak <kzak@redhat.com>2009-11-09 16:45:50 +0100
committerKarel Zak <kzak@redhat.com>2009-11-09 16:45:50 +0100
commitbf12cd21d19df347065f0fcd63dff4f6966ecee1 (patch)
tree8bdebb4cb5bab68b8f5774a1185086399ce2a281 /mount/Makefile.am
parent0f6f03e628346cf3b90e13f6e6615d68b51be086 (diff)
downloadutil-linux-old-bf12cd21d19df347065f0fcd63dff4f6966ecee1.tar.gz
build-sys: cleanup AM_CFLAGS usage
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'mount/Makefile.am')
-rw-r--r--mount/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/mount/Makefile.am b/mount/Makefile.am
index ca44d007..c5f58aa3 100644
--- a/mount/Makefile.am
+++ b/mount/Makefile.am
@@ -23,16 +23,16 @@ srcs_mount = fstab.c mount_mntent.c getusername.c lomount.c devname.c devname.h
# between CFLAGS and CPPFLAGS, we follow this behaviour and use CFLAGS only.
ldadd_common =
ldadd_static =
-cflags_common =
+cflags_common = $(AM_CFLAGS)
ldflags_static = -all-static
mount_SOURCES = mount.c $(srcs_mount) ../lib/setproctitle.c
-mount_CFLAGS = $(SUID_CFLAGS) $(AM_CFLAGS) $(cflags_common)
+mount_CFLAGS = $(SUID_CFLAGS) $(cflags_common)
mount_LDFLAGS = $(SUID_LDFLAGS) $(AM_LDFLAGS)
mount_LDADD = $(ldadd_common)
umount_SOURCES = umount.c $(srcs_mount)
-umount_CFLAGS = $(SUID_CFLAGS) $(AM_CFLAGS) $(cflags_common)
+umount_CFLAGS = $(SUID_CFLAGS) $(cflags_common)
umount_LDFLAGS = $(SUID_LDFLAGS) $(AM_LDFLAGS)
umount_LDADD = $(ldadd_common)