summaryrefslogtreecommitdiff
path: root/mount/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak <kzak@redhat.com>2007-10-25 12:29:51 +0200
committerKarel Zak <kzak@redhat.com>2007-10-26 01:02:12 +0200
commitbfdb8be5c49d8fadb25118fb4416ab2a68fc3a16 (patch)
treea8502661b829ef0f5db2f28f43eca3cf799c7b5e /mount/Makefile.am
parent0e7cd33ef2d2e6307c5f647f0434e54bcc0f62e2 (diff)
downloadutil-linux-old-bfdb8be5c49d8fadb25118fb4416ab2a68fc3a16.tar.gz
losetup: canonicalize loopfile name
When setting up a loop device, canonicalize the loop file name. This simplifies a later identification of loop file names when querying the loop devices. Co-Author: Matthias Koenig <mkoenig@suse.de> Signed-off-by: Matthias Koenig <mkoenig@suse.de> Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'mount/Makefile.am')
-rw-r--r--mount/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/mount/Makefile.am b/mount/Makefile.am
index 57a5af8d..46bcb5ab 100644
--- a/mount/Makefile.am
+++ b/mount/Makefile.am
@@ -25,8 +25,8 @@ umount_LDFLAGS = $(SUID_LDFLAGS) $(AM_LDFLAGS)
swapon_SOURCES = swapon.c swap_constants.h $(utils_common)
-losetup_SOURCES = lomount.c sundries.c xmalloc.c loop.h lomount.h xmalloc.h \
- sundries.h
+losetup_SOURCES = lomount.c sundries.c xmalloc.c realpath.c \
+ loop.h lomount.h xmalloc.h sundries.h realpath.h
losetup_CPPFLAGS = -DMAIN $(AM_CPPFLAGS)
mount_LDADD = $(LDADD_common)