summaryrefslogtreecommitdiff
path: root/shlibs/mount/src/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak <kzak@redhat.com>2011-01-19 23:51:12 +0100
committerKarel Zak <kzak@redhat.com>2011-01-22 00:27:26 +0100
commit2a1f429ad01dc00cd73f1f9ca39e6920687ea414 (patch)
treed5d3989e449fe092f4aa6bef05323818540c19f2 /shlibs/mount/src/Makefile.am
parentdbde192307f899cfa1a6ea014eebbc58c0174a42 (diff)
downloadutil-linux-old-2a1f429ad01dc00cd73f1f9ca39e6920687ea414.tar.gz
libmount: rename mount.h to libmount.h
The mount.h file name is too generic. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'shlibs/mount/src/Makefile.am')
-rw-r--r--shlibs/mount/src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/shlibs/mount/src/Makefile.am b/shlibs/mount/src/Makefile.am
index f552ebee..ceea6ab5 100644
--- a/shlibs/mount/src/Makefile.am
+++ b/shlibs/mount/src/Makefile.am
@@ -5,8 +5,8 @@ AM_CPPFLAGS += -I$(ul_libmount_incdir) \
-I$(ul_libblkid_incdir)
# includes
-mountincdir = $(includedir)/mount
-nodist_mountinc_HEADERS = mount.h
+mountincdir = $(includedir)/libmount
+nodist_mountinc_HEADERS = libmount.h
usrlib_exec_LTLIBRARIES = libmount.la
libmount_la_SOURCES = mountP.h version.c utils.c test.c init.c cache.c \
@@ -25,7 +25,7 @@ nodist_libmount_la_SOURCES = mountP.h
libmount_la_LIBADD = $(ul_libblkid_la) $(SELINUX_LIBS)
-libmount_la_DEPENDENCIES = $(libmount_la_LIBADD) mount.sym mount.h.in
+libmount_la_DEPENDENCIES = $(libmount_la_LIBADD) mount.sym libmount.h.in
libmount_la_LDFLAGS = -Wl,--version-script=$(ul_libmount_srcdir)/mount.sym \
-version-info $(LIBMOUNT_VERSION_INFO)
@@ -36,7 +36,7 @@ if HAVE_SELINUX
TESTS_LIBS += $(SELINUX_LIBS)
endif
-EXTRA_DIST = mount.sym mount.h.in
+EXTRA_DIST = mount.sym libmount.h.in
CLEANFILES = $(tests)
# move lib from $(usrlib_execdir) to $(libdir) if needed