summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 0f008b30..2a185f34 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -3,13 +3,22 @@ include $(top_srcdir)/config/include-Makefile.am
AM_CPPFLAGS += -DTEST_PROGRAM
noinst_PROGRAMS = test_blkdev test_ismounted test_wholedisk test_mangle \
- test_strtosize
+ test_strtosize test_tt
+if LINUX
+if HAVE_CPU_SET_T
+noinst_PROGRAMS += test_cpuset
+endif
+endif
test_blkdev_SOURCES = blkdev.c
test_ismounted_SOURCES = ismounted.c
test_wholedisk_SOURCES = wholedisk.c
test_mangle_SOURCES = mangle.c
test_strtosize_SOURCES = strtosize.c
+if LINUX
+test_cpuset_SOURCES = cpuset.c
+endif
+test_tt_SOURCES = tt.c
if LINUX
test_blkdev_SOURCES += linux_version.c