summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMarco d'Itri <md@linux.it>2015-03-15 04:09:25 +0100
committerMarco d'Itri <md@linux.it>2015-04-24 15:23:59 +0200
commitd4039a5a578072dc2ce93256c02645b9cdf856f3 (patch)
tree1fc4869c9fd98af641090d7017cbfd60069e91ac /debian/rules
parentc9af7b9cb6645f29dfe0d8001db7137f89535226 (diff)
downloadwhois-d4039a5a578072dc2ce93256c02645b9cdf856f3.tar.gz
Clean up debian/rules
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 8 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index b975132..179a446 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,8 +1,9 @@
#!/usr/bin/make -f
SHELL+= -e
-DEB_HOST_GNU_TYPE := $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE := $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+-include /usr/share/dpkg/architecture.mk
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
ifneq ($(DEB_HOST_GNU_TYPE),$(DEB_BUILD_GNU_TYPE))
export CC := $(DEB_HOST_GNU_TYPE)-gcc
@@ -24,9 +25,10 @@ clean:
$(MAKE) distclean
dh_clean
-binary-arch: checkroot build
+binary-arch: build
dh_testdir
- dh_clean
+ dh_testroot
+ dh_prep
dh_installdirs usr/bin
$(MAKE) install BASEDIR=$D
@@ -40,7 +42,7 @@ binary-arch: checkroot build
dh_installdeb
dh_gencontrol
dh_md5sums
- dh_builddeb -- -Zxz
+ dh_builddeb
binary: binary-arch
@@ -49,7 +51,4 @@ binary-indep:
build-arch: build
build-indep: build
-checkroot:
- test root = "`whoami`"
-
-.PHONY: binary binary-arch binary-indep build build-arch build-indep clean checkroot
+.PHONY: binary binary-arch binary-indep build build-arch build-indep clean