summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMarco d'Itri <md@linux.it>2005-11-27 13:43:35 +0100
committerMarco d'Itri <md@linux.it>2013-03-30 02:31:33 +0100
commitf5a3fd9e48ea528710c38ccf24104d30249a3af6 (patch)
tree9cd13def677cd0ecf98e99c9ec9ba00218b88b46 /debian/rules
parent7a1cc2f4227a6d59be53d71451992a51ad801b20 (diff)
downloadwhois-f5a3fd9e48ea528710c38ccf24104d30249a3af6.tar.gz
Imported Debian version 4.7.9v4.7.9
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 5 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 6d684a0..3a17e7f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,8 @@ SHELL+= -e
D := $(shell pwd)/debian/whois
+VERSION := $(shell dpkg-parsechangelog | sed -n '/^Version/s/.* //p')
+
build:
dh_testdir
make whois mkpasswd \
@@ -22,6 +24,9 @@ binary-arch: checkroot build
dh_testdir
dh_clean
+ # sanity check
+ egrep -q '^#define VERSION "$(VERSION)"$$' config.h
+
dh_installdirs usr/bin
install whois mkpasswd $D/usr/bin/
cd po && make install BASEDIR=$D