summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules55
1 files changed, 4 insertions, 51 deletions
diff --git a/debian/rules b/debian/rules
index b975132..1f4c033 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,55 +1,8 @@
#!/usr/bin/make -f
-SHELL+= -e
-DEB_HOST_GNU_TYPE := $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE := $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+%:
+ dh $@
-ifneq ($(DEB_HOST_GNU_TYPE),$(DEB_BUILD_GNU_TYPE))
- export CC := $(DEB_HOST_GNU_TYPE)-gcc
-endif
+override_dh_auto_build:
+ $(MAKE) CONFIG_FILE="/etc/whois.conf" HAVE_ICONV=1
-DPKG_EXPORT_BUILDFLAGS = 1
--include /usr/share/dpkg/buildflags.mk
-
-D := $(CURDIR)/debian/whois
-
-build:
- dh_testdir
- $(MAKE) CONFIG_FILE="/etc/whois.conf" HAVE_LIBIDN=1 HAVE_ICONV=1
- touch $@
-
-clean:
- dh_testdir
- -rm -f build
- $(MAKE) distclean
- dh_clean
-
-binary-arch: checkroot build
- dh_testdir
- dh_clean
-
- dh_installdirs usr/bin
- $(MAKE) install BASEDIR=$D
- dh_installman whois.1 mkpasswd.1
- dh_installdocs README
- dh_installchangelogs
- dh_strip
- dh_compress
- dh_fixperms
- dh_shlibdeps
- dh_installdeb
- dh_gencontrol
- dh_md5sums
- dh_builddeb -- -Zxz
-
-binary: binary-arch
-
-binary-indep:
-
-build-arch: build
-build-indep: build
-
-checkroot:
- test root = "`whoami`"
-
-.PHONY: binary binary-arch binary-indep build build-arch build-indep clean checkroot