summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorCyril Brulebois <kibi@debian.org>2010-10-31 16:12:00 +0100
committerCyril Brulebois <kibi@debian.org>2010-10-31 16:12:00 +0100
commit381d929587ce84005a8e0f1f54c44d3c5d7fb8cc (patch)
treed570b271229e7d7d28156f8a3ca30be55882b35c /debian/rules
parent4034964c2cfc38b5a28f8fa1bac1f068a5187024 (diff)
downloadxutils-dev-381d929587ce84005a8e0f1f54c44d3c5d7fb8cc.tar.gz
Introduce SUBDIRS_CHECK where one can list packages which implement a testsuite. Put makedepend in it.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 6 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 09d76a6..cd1a896 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,6 +15,7 @@ include debian/xsfbs/xsfbs.mk
# This package contains multiple modules as shipped by upstream. Each module is # contained in a subdirectory in the root dir of the package. You must list each
# subdirectory explicitly so that the build system knows what to build
SUBDIRS= gccmakedep imake lndir makedepend util-macros xorg-cf-files
+SUBDIRS_CHECK= makedepend
CFLAGS = -Wall -g
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
@@ -49,6 +50,11 @@ $(STAMP_DIR)/build-%: $(STAMP_DIR)/patch
CFLAGS="$(CFLAGS)"
cd $*-build && \
$(MAKE)
+ # Possible "make check":
+ if echo $(SUBDIRS_CHECK) | grep -qs "\<$*\>"; then \
+ cd $*-build && \
+ $(MAKE) check; \
+ fi
>$@
clean: xsfclean