summaryrefslogtreecommitdiff
path: root/debian/xsfbs
diff options
context:
space:
mode:
authorBrice Goglin <Brice.Goglin@ens-lyon.org>2007-07-09 21:50:47 +0200
committerBrice Goglin <Brice.Goglin@ens-lyon.org>2007-07-09 21:50:47 +0200
commite29b56820909668b062fdba72458ee9483a4ae44 (patch)
tree7d5923d2227ab6d3aeaa361c989827b75af586a0 /debian/xsfbs
parent16d97b30b91da02d5a3edc2b895cbd4a1995f62d (diff)
downloadxutils-dev-e29b56820909668b062fdba72458ee9483a4ae44.tar.gz
Minor fixes in the patching system.
* Fix debian/rules to not be confused by ~/.quiltrc or QUILT_PATCHES (as in #369920). * Display which patches are applied and removed instead of just the first one (for #428090).
Diffstat (limited to 'debian/xsfbs')
-rwxr-xr-xdebian/xsfbs/xsfbs.mk23
1 files changed, 14 insertions, 9 deletions
diff --git a/debian/xsfbs/xsfbs.mk b/debian/xsfbs/xsfbs.mk
index 2930c1e..5f13302 100755
--- a/debian/xsfbs/xsfbs.mk
+++ b/debian/xsfbs/xsfbs.mk
@@ -21,6 +21,11 @@
# Pass $(DH_OPTIONS) into the environment for debhelper's benefit.
export DH_OPTIONS
+# force quilt to not use ~/.quiltrc
+QUILT = quilt --quiltrc /dev/null
+# force QUILT_PATCHES to the default in case it is exported in the environment
+QUILT_PATCHES = patches/
+
# Set up parameters for the upstream build environment.
# Determine (source) package name from Debian changelog.
@@ -140,9 +145,9 @@ $(STAMP_DIR)/patch: $(STAMP_DIR)/prepare
echo "Couldn't find quilt. Please install it or add it to the build-depends for this package."; \
exit 1; \
fi; \
- if quilt next >/dev/null 2>&1; then \
+ if $(QUILT) next >/dev/null 2>&1; then \
echo -n "Applying patches..."; \
- if quilt push -a -v 2>&1 | tee $(STAMP_DIR)/log/patch; then \
+ if $(QUILT) push -a -v 2>&1 | tee $(STAMP_DIR)/log/patch; then \
echo "successful."; \
else \
echo "failed! (check $(STAMP_DIR)/log/patch for details)"; \
@@ -159,7 +164,7 @@ unpatch:
rm -f $(STAMP_DIR)/patch
@echo -n "Unapplying patches..."; \
if [ -e $(STAMP_DIR)/patches/applied-patches ]; then \
- if quilt pop -a -v 2>&1 | tee $(STAMP_DIR)/log/unpatch; then \
+ if $(QUILT) pop -a -v 2>&1 | tee $(STAMP_DIR)/log/unpatch; then \
echo "successful."; \
else \
echo "failed! (check $(STAMP_DIR)/log/unpatch for details)"; \
@@ -295,17 +300,17 @@ patch-audit: prepare unpatch
@echo -n "Auditing patches..."; \
>$(STAMP_DIR)/log/patch; \
FUZZY=; \
- while [ -n "$$(quilt next)" ]; do \
- RESULT=$$(quilt push -v | tee -a $(STAMP_DIR)/log/patch | grep ^Hunk | sed 's/^Hunk.*\(succeeded\|FAILED\).*/\1/');\
+ while [ -n "$$($(QUILT) next)" ]; do \
+ RESULT=$$($(QUILT) push -v | tee -a $(STAMP_DIR)/log/patch | grep ^Hunk | sed 's/^Hunk.*\(succeeded\|FAILED\).*/\1/');\
case "$$RESULT" in \
succeeded) \
- echo "fuzzy patch: $$(quilt top)" \
- | tee -a $(STAMP_DIR)/log/$$(quilt top); \
+ echo "fuzzy patch: $$($(QUILT) top)" \
+ | tee -a $(STAMP_DIR)/log/$$($(QUILT) top); \
FUZZY=yes; \
;; \
FAILED) \
- echo "broken patch: $$(quilt next)" \
- | tee -a $(STAMP_DIR)/log/$$(quilt next); \
+ echo "broken patch: $$($(QUILT) next)" \
+ | tee -a $(STAMP_DIR)/log/$$($(QUILT) next); \
exit 1; \
;; \
esac; \