summaryrefslogtreecommitdiff
path: root/xorg-cf-files/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-cf-files/configure.ac')
-rw-r--r--xorg-cf-files/configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/xorg-cf-files/configure.ac b/xorg-cf-files/configure.ac
new file mode 100644
index 0000000..fbed1c3
--- /dev/null
+++ b/xorg-cf-files/configure.ac
@@ -0,0 +1,19 @@
+AC_PREREQ([2.57])
+AC_INIT(xorg-cf-files, [1.0.1], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], xorg-cf-files)
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
+AM_MAINTAINER_MODE
+
+m4_ifdef([AS_HELP_STRING], , [m4_define([AS_HELP_STRING], m4_defn([AC_HELP_STRING]))])
+
+DEFAULT_XCONFDIR="${libdir}/X11/config"
+AC_ARG_WITH(config-dir,
+ AS_HELP_STRING([--with-config-dir=<path>], [Path to config dir (default: ${libdir}/X11/config)]),
+ [XCONFDIR="$withval"],
+ [XCONFDIR="$DEFAULT_XCONFDIR"])
+AC_SUBST(XCONFDIR)
+
+XORG_RELEASE_VERSION
+
+AC_OUTPUT([
+ Makefile
+])