summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2011-06-01 14:42:01 +0100
committerSimon McVittie <smcv@debian.org>2011-06-01 14:42:01 +0100
commit2f9806511294feb614da3c217a8b992527eb6e68 (patch)
treee72e31f821a6048840786e46728e384d01eff6aa /debian
parentdbe142d163a78eafa2abf1d4b0d32ab9c5ff28fc (diff)
downloaddbus-2f9806511294feb614da3c217a8b992527eb6e68.tar.gz
Use hardening-includes to get PIE and stuff
Diffstat (limited to 'debian')
-rw-r--r--debian/control1
-rwxr-xr-xdebian/rules10
2 files changed, 9 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index a91b2d5b..5281bfd3 100644
--- a/debian/control
+++ b/debian/control
@@ -12,6 +12,7 @@ Build-Depends: autotools-dev,
dh-autoreconf,
doxygen,
dpkg-dev (>= 1.16.0~ubuntu4),
+ hardening-includes,
libexpat-dev,
libselinux1-dev [linux-any],
libx11-dev,
diff --git a/debian/rules b/debian/rules
index 7fca39a1..4f57d924 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,8 +11,14 @@ libdbusN := $(shell sed -rn 's/Package:[[:space:]]*(libdbus-[0-9-]+)[[:space:]]*
multiarch := $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
cflags := $(shell dpkg-buildflags --get CFLAGS)
-ldflags := $(shell dpkg-buildflags --get LDFLAGS) -Wl,--as-needed
-common_configure_flags = \
+ldflags := $(shell dpkg-buildflags --get LDFLAGS)
+ldflags += -Wl,--as-needed
+
+include /usr/share/hardening-includes/hardening.make
+cflags += $(HARDENING_CFLAGS)
+ldflags += $(HARDENING_LDFLAGS)
+
+common_configure_flags := \
--disable-libaudit \
--libexecdir=\$${prefix}/lib/dbus-1.0 \
--htmldir=\$${prefix}/share/doc/dbus \